Bug 89882 - p2fs fixes
p2fs fixes
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Ross
Jon Orris
:
Depends On:
Blocks: 88926
  Show dependency treegraph
 
Reported: 2003-04-29 08:18 EDT by Richard Li
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-02 17:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Li 2003-04-29 08:18:31 EDT
We need to identify test cases and thoroughly test p2fs. We should also identify
any and all architectural changes we want to make.

Also, please take a look at 29182 to decide if it should be merged.
Comment 1 Richard Li 2003-04-29 08:23:08 EDT
Also please decide whether or not merging 29180 is appropriate.
Comment 2 Richard Li 2003-04-29 08:23:32 EDT
And 29056.
Comment 3 Richard Li 2003-05-29 09:36:30 EDT
David, can you comment on the three changelists above (and any others that may
be relevant?). Thanks.
Comment 4 David Lutterkort 2003-05-29 14:00:33 EDT
@29182: Having PFS responsible for deleting empty live bundles and folders is
really ugly. I had to put this back into WCMS since there is some pretty screwed
up, DP specific code that depends on it (the DP-specific move functionality).
For core CMS, it would be much cleaner if live bundles and folders were deleted
when the last instance/item in them is unpublished. PFS doesn't really care
either way.

@29180: This invariant should be added to core CMS; if live and draft
bundles/folders are not in the right position, horrible things will happen; in
particular, publishing new items in them will make them appear in the wrong
place on the live site.

@29056: AFAIK, SystemWideReader wasn't pulled into core; it is very DP specific.
It is used to log in as a special user which is then used to make the requests
back to the editorial server from PFS. Core CMS might need something there if
read access to live items on the editorial server is ever restricted via the
public viewers group, but the code in this changelist is very DP-specific and
most likely not useful for core CMS.
Comment 5 Richard Li 2003-06-02 17:39:52 EDT
Invariant is merged (and ported to ANSI standard SQL so that it runs in both PG
and Oracle).
Comment 6 Justin Ross 2003-06-05 12:42:08 EDT
Regarding the first paragraph of David's comment, change 31978 makes item
unpublish recursively unpublish parents that are empty folders or empty bundles.

Note You need to log in before you can comment on or make changes to this bug.