Bug 8993 - rpm --rebuild nukes database !!!!!
Summary: rpm --rebuild nukes database !!!!!
Status: CLOSED DUPLICATE of bug 8752
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-30 21:31 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-31 16:03:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-01-30 21:31:32 UTC
"rpm --rebuild" gives the following output:
temporary database /var/lib/rpm already exists
error creating directory /var/lib/rpm: File exists

And then continues, this results in the database being rebuild on top of
the exisisting one, resulting in a double database. rpm -q foo gives 2x
foo, and rpm -e foo says that foo desribes multiple packages ;|

I had to re install to get things fixed ;|

This is a severe bug!!

Comment 1 Jeff Johnson 2000-01-31 16:03:59 UTC
*** This bug has been marked as a duplicate of 8752 ***


Note You need to log in before you can comment on or make changes to this bug.