Bug 8994 - panel clocks loosing time
panel clocks loosing time
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 16:45 EST by Hans de Goede
Modified: 2013-04-02 00:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-11 09:42:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-01-30 16:45:09 EST
I have this problem bith with the regular clock-applet and with the
afterstep clock, so it's probably somewhere in soem code they share.

The easiest way to reproduce it is:
set clock forward with date -s
wait for clock to catch up.
set clock back to real time.
clock doesn't catch up untill the time passes the time it was set forward
too.

This is might seem a small bug but for some reason the clocks also
decide to jump an hour forward after each suspend / resume cycle.
(probably has something todo with my time zone which is gmt-1)

I think that if the simple problem is fixed the complex problem will be
hidden, but I don't care as long as my clock shows the correct time.

And then it takes an hour before it show a usable time again, if my laptop
/ system doesn't suspend before that.
Comment 1 Jonathan Blandford 2000-02-04 14:51:59 EST
This has finally been fixed, and was just put in Rawhide.
Comment 2 Hans de Goede 2000-02-13 09:51:59 EST
I just tried gnome-core-1.0.55-7 (dated 02/09/00)
And this bug still seems present both in the normal and Afterstep clock, I used
the method described above to make the clock freeze.
Comment 3 Jonathan Blandford 2000-02-13 19:12:59 EST
Sorry, I should have been more clear.  The bug was in gtk+, so try upgrading
that see if it fixes it.  If this doesn't fix it, reopen the bug, and we'll try
to figure it out, but it seems to work here. (TM)
Comment 4 Hans de Goede 2000-02-14 01:54:59 EST
I still have the problem with gtk+-1.2.6-5, the latest I can get my hands on, in
which version should it be fixed?
Comment 5 Hans de Goede 2000-03-02 05:33:59 EST
Running with the latest gnome-core gnome-libs and gtk from the snapshots dir on
ftp.beta.redhat.com I still have this problem. Even worse if I now set the time
backwards not only the clock freezes, but also sawmill.

I do get a few heuh time seems to be traveling backwards messages in my Xlog
Comment 6 Hans de Goede 2000-03-11 09:39:59 EST
Okay, this bug is fixed for me in the 4 march snapshot, so I'm closing it,
the sawmill problem still is there, but the clock problem is gone.

So I'll open a new bug report for sawmill.

In the meanwhile I'm closing this one.

Note You need to log in before you can comment on or make changes to this bug.