Bug 89954 - Can not link to libglut.so
Can not link to libglut.so
Status: CLOSED DUPLICATE of bug 90734
Product: Red Hat Linux
Classification: Retired
Component: glut (Show other bugs)
9
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-30 06:21 EDT by Michel Fodje
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Fodje 2003-04-30 06:21:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030313 Galeon/1.3.4

Description of problem:
Can not link GLUT programs with the version of libglut.so distributed with RedHat 9 



Version-Release number of selected component (if applicable):
glut-3.7-12

How reproducible:
Always

Steps to Reproduce:
1.  create file: test.c
---
#include <GL/gl.h>
#include <GL/glu.h>
#include <GL/glut.h>

int main(int argc, char **argv){
	return;
	glutInit(&argc, argv);
	glutInitWindowSize(512,512);
	glutInitDisplayMode(GLUT_RGB|GLUT_DEPTH|GLUT_DOUBLE);
	glutCreateWindow("Test");
	glutMainLoop();
	return 0;
}
---

2.  gcc -o test test.c  -L/usr/X11R6/lib -lglut -lGL -lGLU -lX11 -lXmu -lXext -lXi
    

Actual Results:  
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXBindChannelToWindowSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXQueryChannelDeltasSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXChannelRectSyncSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXChannelRectSGIX'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined
reference to `glXQueryChannelRectSGIX'


Expected Results:  should produce an executable test binary

Additional info:

-NVIDIA drivers verion 1.0-4349 are installed on the test system
-Recompiling glut from srpm and installing that instead, fixes the problem.
Comment 1 Mike Chambers 2003-05-01 09:17:44 EDT
Are you using nVidia binary drivers when trying to do this instead of the
supplied nv driver from XFree86?

If so, you need to be using the supplied nv driver from XFree86, then try to
link to libglut.so to see if it works or not.

When using the nVidia binary driver, you have tainted the system with specs that
no one has access to outside of nVidia, therefore no way of troubleshooting any
problems.

Please use the nv driver instead, then try to link to libglut.so with the
original glut package that came with Shrike to see if that works.
Comment 2 Michel Fodje 2003-05-01 13:34:25 EDT
You are right! It works with the "nv" driver.  This appears to be a problem with
the NVIDIA driver and not glut. So I'm closing this bug. Marking it as WONTFIX
and reporting the problem to NVIDIA.
Comment 3 Mike A. Harris 2003-05-13 04:02:22 EDT

*** This bug has been marked as a duplicate of 90734 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:52:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.