Bug 89956 - Hungarian localication files *64136.res aren't used
Hungarian localication files *64136.res aren't used
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-30 06:57 EDT by Zoltán Böszörményi
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 11:21:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zoltán Böszörményi 2003-04-30 06:57:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
There is a hungarian localization project of the OOo at
http://office.fsf.hu and with RedHat 8.0's openoffice-1.0.1
it (the at that time current res-046-01.tar.gz, the 46th build of the
localization) worked because the resource files used *64101.res
names and they overwrote the en_US files.

The current resource files are now using *64136.res file names.
They can be found at:
http://office.fsf.hu/work/res-1.0.2-fsfhu-20030403.tar.bz2 or
http://office.fsf.hu/work/res-1.0.3-fsfhu-20030427.tar.bz2

The splash screen now uses the modified bitmap that has "FSF.hu magyar verzi�o"
signature in it but the menus are not hungarian.

The full hungarian openoffice downloadable from
http://office.fsf.hu/work/oo-1.0.2-fsfhu-20030403.tar.bz2 or
http://office.fsf.hu/work/oo-1.0.3-fsfhu-20030427.tar
seem to work and they contain *64136.res files.

Version-Release number of selected component (if applicable):
1.0.2-4

How reproducible:
Always

Steps to Reproduce:
1. copy the *64136.res files into
   /usr/lib/openoffice/program/resource
2. start any program of openoffice with LANG=hu_HU.utf8

Actual Results:  The menus are still english.

Expected Results:  The menus should be hungarian because of the LANG setting.

Additional info:
If the *64136.res files are renamed to *64101.res the menus are now hungarian
but it is not a clean solution.
Comment 1 Zoltán Böszörményi 2003-05-23 02:01:42 EDT
It is solved by editing
~/.openoffice/user/config/registry/instance/org/openoffice/Setup.xml
by hand so the "ooLocale" property line reads as follows:
<ooLocale cfg:type="string">hu-HU</ooLocale>

But it should follow the LANG setting from the environment.
Comment 2 Dan Williams 2004-02-27 11:21:15 EST
Please try current OOo 1.1.0, and reopen if problem still occurs

Note You need to log in before you can comment on or make changes to this bug.