Bug 8996 - not responding to save yourself is trigger happy
not responding to save yourself is trigger happy
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-30 16:56 EST by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 15:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-01-30 16:56:43 EST
The timeout for the not responding to the save yourself command phase 2
is way too short. On my old sparc ipx it keeps popping up even if the
machine is fully idle. And I mean fully idle, I'm not even moving the mouse
ptr. VERY VERY anoying

Isn't the idea of a timeout that it is the not regular path, and thus may
be quite long?
Comment 1 Owen Taylor 2000-02-03 15:18:59 EST
The short answer is that your machine is too slow, or does not have
enough memory to run GNOME. You may want to consider running your
system with a simpler desktop environment such as AnotherLevel.

The timeout here is 10 seconds, so it is taking more than 10 seconds
for some application to respond to the session manager.

The problem with making it longer by default, is that if you have a GNOME
application stopped in the background, when the user tries to logout,
the logout will just hang until this timeout expires.

However, you can change the timeout on your system, by editing the
the line /etc/X11/xdm/Xsession:

 exec gnome-session

to

 exec gnome-session --warn-delay 120000

where the number is the timeout in milliseconds.

It's also conceivable that there is some bug that is particular to
your setup in effect, since I don't understand why you would be
getting these messages when your system is sitting there idle. If the above
explanation (that your machine is just too slow) doesn't sound reasonable, you
may want to provide additional information about the circumstances
in which you see these messages.
Comment 2 Hans de Goede 2000-02-03 17:45:59 EST
The system involved is indeed slow, it is an old sparc which is the equivalent
of a 486dx33. It isn't swapping so ram is not the problem.

And I'm normally using anotherlevel, but I thought gnome should work on it too.

I'm happy with the --warn-delay option, it helps me. May I suggest though, that
the popup box is made a bit more clear, I've also seen this happen once or twice
on a PII 300 if it was heavily loaded, and when that happenend it has managed to
confuse the user sitting behind it. So maybe state very clearly that this usual
is due to the system being slow temporarily.

Besides that you might add the following sentence:
Anoyed? try executing gnome-session with --warn-delay <large time in xxxxs>

Please fill in xxxxs yourself. This might not really help a newbie, but it would
have saved you this bugreport, since then I would have been able to solve it
myself ;)

I think that it even might be worth a controlcenter applet, making it easy to
fix for a newbie too, and allowing easy access to other gnome-session settings
too. Anyways just my 2 cents

Note You need to log in before you can comment on or make changes to this bug.