Bug 89965 - Could --rollback print the rollback goal in seconds since epoch
Could --rollback print the rollback goal in seconds since epoch
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-30 09:18 EDT by James Olin Oden
Modified: 2007-03-27 00:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-30 09:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to print rollback goal (297 bytes, patch)
2003-04-30 09:20 EDT, James Olin Oden
no flags Details | Diff

  None (edit)
Description James Olin Oden 2003-04-30 09:18:59 EDT
Description of problem:
For debuging purposes it would be really nice if rpm would print the 
rollback goal in seconds since epoch when a rollback is requested.

Version-Release number of selected component (if applicable):
4.2-0.69

How reproducible:
N/A

Steps to Reproduce:
N/A
    
Actual results:
N/A

Expected results:
N/A

Additional info:
Comment 1 James Olin Oden 2003-04-30 09:20:18 EDT
Created attachment 91419 [details]
Patch to print rollback goal
Comment 2 Jeff Johnson 2003-04-30 09:29:29 EDT
The rollback goal is compared with transaction id's.

Transaction id's are 4 byte ints with the property of ordering.
There are no other guarantees on the value. In fact, there have
been mumblings about changing the contents to something else (not by me).

I'm reluctant to expose the tid value even in debugging messages
lest INSTALLTIME and INSTALLTID, which atm have identical values,
get confused in usage.

However, ctime(3) is easy, and I'm not about to tell you what to do. ;-)

Note You need to log in before you can comment on or make changes to this bug.