Bug 89979 - Please consider adding mhash support to PHP RPM's.
Please consider adding mhash support to PHP RPM's.
Status: CLOSED DUPLICATE of bug 80591
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-04-30 14:54 EDT by Brian Baggett
Modified: 2007-03-27 00:03 EDT (History)
0 users

See Also:
Fixed In Version: 80591
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:52:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian Baggett 2003-04-30 14:54:24 EDT
In writing an LDAP manipulation tool in PHP, I've found that I need the mhash
libraries for generating MD5 and SHA1 passwords from within PHP.  While I could
(and probably will) build an RPM of mhash and rebuild my RPM of PHP to include
it in the same way it's currently done to accomodate IMAP and LDAP, I am hoping
that you will consider adding this soon.  There are folks on the web who are
building RPM's with this in the same manner I'm describing, but it would nice to
see Redhat bless such an RPM.

Mhash is LGPL software (http://sourceforge.net/projects/mhash)

PHP.net's site on mhash: http://www.php.net/manual/en/ref.mhash.php
mhash's homepage: http://mhash.sourceforge.net

Thank you,
Comment 1 Joe Orton 2003-05-06 11:02:06 EDT
PHP already includes an MD5 extension - PHP 4.3 includes a SHA1 extension too,
so I'm marking this a duplicate of the RFE for 4.3.
Comment 2 Joe Orton 2003-05-06 11:03:10 EDT
Really marking as duplicate.

*** This bug has been marked as a duplicate of 80591 ***
Comment 3 Brian Baggett 2003-05-06 11:24:09 EDT
The MD5 and SHA1 functions inherent to PHP that you refer to (ie without mhash)
aren't suitable for generating MD5 and/or SHA1 passwords, are they?
Comment 4 Joe Orton 2003-05-06 11:28:34 EDT
Don't see why not - mhash gives you hashes of arbitrary data (e.g. passwords)
using standard algorithms, just the same as the sha1/md5 extensions.
Comment 5 Joe Orton 2003-05-06 11:39:43 EDT
Though mhash would be much faster, of course.   The best route would be to
extend the openssl extension to use the OpenSSL digest interfaces.
Comment 6 Red Hat Bugzilla 2006-02-21 13:52:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.