Bug 89990 - PCMCIA support fails on Acer Travelmate 230
PCMCIA support fails on Acer Travelmate 230
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-30 17:26 EDT by Michal Jaegermann
Modified: 2015-01-04 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:22:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2003-04-30 17:26:47 EDT
Description of problem:

On Acer Travelmate 230 one can find the following in 'dmesg':

Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
PCI: No IRQ known for interrupt pin A of device 02:09.0. Please try using
pci=biosirq.
ds: no socket drivers loaded!

"pci=biosirq" does not help at all and 'ds' and 'yenta_socket' fail to load.
'modprobe' ends up, not very surprinsingly, with

init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.

OTOH this laptop has a widely used OZ6912 Cardbus Controller, which is specifically
listed as supported in PCMCIA-HOWTO, and one can find a confirmation of that in
many places on the net.  Also current Knoppix kernel when  startd on the machine
in question at least loads 'yenta_socket' and 'ds' modules.  It is difficult to
say for
me how this works as at this moment I do not have any cards to check. :-)
Probably not at this moment as IRQ assigned is still 0.

This may something to do with the fact that this laptop supports, and apparently
assumes, ACPI for its various functions.  It can be seen in "e820 map":
..............
 BIOS-e820: 000000000f760000 - 000000000f76e000 (ACPI data)
 BIOS-e820: 000000000f76e000 - 000000000f780000 (ACPI NVS)
........
but ACPI is turned off in a kernel configuration.

Version-Release number of selected component (if applicable):
kernel-2.4.20-9 and kernel-pcmcia-cs-3.1.31-13

Additional info:

An output from 'lspci -tv'

-[00]-+-00.0  Intel Corp. 82845G/GL [Brookdale-G] Chipset Host Bridge
      +-02.0  Intel Corp. 82845G/GL [Brookdale-G] Chipset Integrated Graphics Device
      +-1d.0  Intel Corp. 82801DB USB (Hub #1)
      +-1d.1  Intel Corp. 82801DB USB (Hub #2)
      +-1d.2  Intel Corp. 82801DB USB (Hub #3)
      +-1d.7  Intel Corp. 82801DB USB EHCI Controller
      +-1e.0-[02]--+-05.0  Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
      |            \-09.0  O2 Micro, Inc. OZ6912 Cardbus Controller
      +-1f.0  Intel Corp. 82801DB ISA Bridge (LPC)
      +-1f.1  Intel Corp. 82801DB ICH4 IDE
      +-1f.3  Intel Corp. 82801DB SMBus
      +-1f.5  Intel Corp. 82801DB AC'97 Audio
      \-1f.6  Intel Corp. 82801DB AC'97 Modem

and from 'lspci -s 2:9.0 -vv'

02:09.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
	Subsystem: Unknown device 17c0:3102
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping-
SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Interrupt: pin A routed to IRQ 0
	Region 0: Memory at 10001000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=02, secondary=03, subordinate=06, sec-latency=32
	I/O window 0: 00000000-00000003
	I/O window 1: 00000000-00000003
	BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset- 16bInt+ PostWrite-
	16-bit legacy interface ports at 0001

PCI id for the device "1217:6972".
Comment 1 Arjan van de Ven 2003-04-30 17:30:46 EDT
	Interrupt: pin A routed to IRQ 0


that's not going to work
Comment 2 Michal Jaegermann 2003-04-30 17:43:26 EDT
Well, yes, I know that with IRQ 0 this will not work.  The question is how to
get some saner IRQ assignment. :-)
Comment 3 Arjan van de Ven 2003-04-30 17:44:22 EDT
PCI IRQ's are asssigned by the bios...... so a bios upgrade ?
Comment 4 Dave 2003-07-15 11:15:47 EDT
I too have the same problem. I too have tried all the above and can verify it 
ain't workin.
Comment 5 Simone Russo 2003-10-02 08:37:31 EDT
Hi... i've tried Debian 3.0 and all works fine. IRQ is correctly assigned and 
wireless pc-card work very well :-/
IMHO this bug can be solved without a bios upgrade
Comment 6 Mike MacCana 2004-01-18 20:20:44 EST
Just confirmed this is still a problem with RHEL3 ES (though I 
haven't tried the first update CD that recently came) 

Note You need to log in before you can comment on or make changes to this bug.