Bug 89996 - USB controller detected; no other USB hubs/devices seen
Summary: USB controller detected; no other USB hubs/devices seen
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: athlon
OS: Linux
medium
low
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-30 22:42 UTC by Julian Missig
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-03 20:34:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/bus/usb/devices (473 bytes, text/plain)
2003-04-30 22:47 UTC, Julian Missig
no flags Details
/sbin/dmesg (7.11 KB, text/plain)
2003-04-30 22:47 UTC, Julian Missig
no flags Details
ls -l /dev/input/mice (72 bytes, text/plain)
2003-04-30 22:48 UTC, Julian Missig
no flags Details
/sbin/lsmod (751 bytes, text/plain)
2003-04-30 22:49 UTC, Julian Missig
no flags Details

Description Julian Missig 2003-04-30 22:42:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b)
Gecko/20030428 Chimera/0.7+

Description of problem:
Filed under 'kernel' only because that's my first guess as to where the problem
might lie..

I think my bug may be the same as this one:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=85933 But I'm not sure an
Pete Zaitcev asked others to file their own bugs.

Anyway, under Red Hat 8 and some of the betas of 9, my USB mouse and keyboard
were working fine. I could see the usb hubs, and the usb devices I connected
(mouse, keyboard, camera, etc.) could be seen fine as well.


Version-Release number of selected component (if applicable):
kernel-2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. Boot system
2. Look for USB devices anywhere
    

Actual Results:  Couldn't find any USB devices. Or any error messages in
/var/log/messages of note.

Expected Results:  USB devices and hubs should be listed and able to be used...

Additional info:


I have a Gigabyte GA-7VAXP motherboard, which uses the VIA KT400 and USB 2.0.
Red Hat selects and uses the ehci-hcd kernel driver for the VIA USB 2.0 Controller.

No USB devices appear in /proc/bus/usb except for 001/001, which is the USB
controller itself. There are no hubs, no mice, no keyboards. Just the controller.

'lsusb' gives me a lot of "Unknown line at line xxx" error messages. (First line
58, then lines 2296 through 2335). It then listes the information for device
001/001, my controller.

One suspicious thing of note is the following two lines from /var/log/messages
(and dmesg):
PCI: 00:10.3 PCI cache line size set incorrectly (32 bytes) by BIOS/FW.
PCI: 00:10.3 PCI cache line size corrected to 64.
PCI device 00:10.3 is my USB controller.

I've tried compiling an official Linus kernel 2.4.20. Still no usb hubs/devices.
I also tried installing the Red Hat 8 2.4.18-27.8.0 kernel. Still no usb
hubs/devices.

I'm pretty certain that this stuff worked fine under Red Hat 8. It works fine
under Windows XP.

Comment 1 Julian Missig 2003-04-30 22:47:20 UTC
Created attachment 91426 [details]
/proc/bus/usb/devices

Comment 2 Julian Missig 2003-04-30 22:47:50 UTC
Created attachment 91427 [details]
/sbin/dmesg

Comment 3 Julian Missig 2003-04-30 22:48:33 UTC
Created attachment 91428 [details]
ls -l /dev/input/mice

Comment 4 Julian Missig 2003-04-30 22:49:23 UTC
Created attachment 91429 [details]
/sbin/lsmod

Comment 5 Julian Missig 2003-05-01 03:46:17 UTC
This seems to have been some sort of problem in upgrading from Red Hat 8 (or one
of the 9 betas) to Red Hat 9. My problem was solved by removing all USB entries
from /etc/sysconfig/hwconf, restarting, letting kudzu add and configure the USB
stuff again and then restarting. I did that a few times and the USB devices all
of a sudden appeared and worked again.

Comment 6 Pete Zaitcev 2003-06-03 03:18:32 UTC
So, can I close this now?

Bill Nottingham says that the upgrade problem was fixed in Anaconda.


Comment 7 Julian Missig 2003-06-03 04:08:37 UTC
Well, if the upgrade problem was solved, sure. :)

Comment 8 Pete Zaitcev 2003-06-03 20:34:19 UTC
OK, now closing the right one. Poor scowles :-)



Note You need to log in before you can comment on or make changes to this bug.