Bug 90021 - password change prevents ssh login
Summary: password change prevents ssh login
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-01 09:50 UTC by Nick Hertl
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-25 12:07:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nick Hertl 2003-05-01 09:50:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
password change prevents ssh login
More info here would simply be repetition of info below.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create new account with some password.
2. Log in as that user via ssh.
3. Run passwd and change password to something else.
4. Try sshing in as that user with either new or old passwords.
5. Try loging into machine from console.
    

Actual Results:  
sshing in with either old or new password fails
console login works

Expected Results:  
both ssh and console login should work

Additional info:

Comment 1 Tomas Mraz 2005-03-25 12:07:25 UTC
This is really strange behaviour which I can't reproduce on recent Fedora/RHEL
distributions and there is not enough info in it.

Reopen if still happens for you with the latest FC/RHEL distribution.



Note You need to log in before you can comment on or make changes to this bug.