Bug 90024 - ipchains no longer needed in Red Hat 9?
Summary: ipchains no longer needed in Red Hat 9?
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ipchains (Show other bugs)
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-01 11:28 UTC by Need Real Name
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-01 18:20:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-05-01 11:28:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
As far as I can tell ipchains is incompatible with the 2.4 kernel
and nothing in Red Hat 9 depends on ipchains. So why is ipchains included in the
distribution now we have iptables?

Request to remove ipchains from Red Hat 9.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.'rpm -e ipchains' removes redundant software from system, with no adverse effects.
    

Additional info:

Comment 1 Mike A. Harris 2003-05-01 18:20:39 UTC
ipchains is compatible with all 2.4 kernels, and is used by many people,
(including myself) which is why it is present in Red Hat Linux.  It has
no real increased maintenance cost to keep it in the distribution, and so
there is no major reason to remove it from the distribution at this point.

It is not redundant software.  It is used by thousands, if not hundreds
of thousands of users and customers who have long established ipchains
firewall rulesets and aren't ready to change them over to iptables just
yet for whatever their individual reasons are.  My personal reason is
because "it just works for me" and I couldn't be bothered to change my
ruleset over to iptables yet even though I know iptables is far superior.

It's a "if it is not broke, don't fix it" thing.

Closing NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.