Bug 90034 - libtool .la files are broken
Summary: libtool .la files are broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: aspell   
(Show other bugs)
Version: 1.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 89925
TreeView+ depends on / blocked
 
Reported: 2003-05-01 14:29 UTC by Joe Orton
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-21 16:38:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2003-05-01 14:29:22 UTC
/usr/lib64/libaspell.la and /usr/lib64/libpspellis broken on Hammer - nobody can
link against this pack

# Directory that this library needs to be installed in:
libdir='/usr/src/build/242548-x86_64/install/usr/lib64'

Comment 1 Joe Orton 2003-05-01 14:31:31 UTC
Oops, hit enter prematurely there.

The .la files are broken on all platforms; they contain bad libdir= lines, which
means they can't be linked against.

# Directory that this library needs to be installed in:
libdir='/usr/src/build/242550-i386/install/usr/lib'

additionally the dependency_libs look bogus:

# Libraries that this one depends upon.
dependency_libs=' -L/usr/lib/gcc-lib/i386-redhat-linux/3.2.2
-L/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../.. -lstdc++ -lm -lc -lgcc_s'


Comment 2 Joe Orton 2003-05-01 14:40:36 UTC
Actually, that's not  true - you *can* link against a .la file with a bad
libdir= line, though you get a warning.  But you can't link against libpspell.la
which has a reference to libaspell.la in the build dir:

dependency_libs=' /usr/src/build/242548-x86_64/install/usr/lib64/libaspell.la

so that's the important thing to fix.

Comment 3 Havoc Pennington 2003-05-01 14:57:12 UTC
Easy fix is to just remove the .la files from the package ;-)

Comment 4 Eido Inoue 2003-05-01 16:33:29 UTC
libaspell.la and libpspell.la removed in release 4


Comment 5 Eido Inoue 2003-05-01 16:46:14 UTC
scratch that. looks like the la files are needed for dynamic loading. they're a
feature. will have to fix the libdir lines.

Comment 6 Florian La Roche 2003-05-20 15:52:13 UTC
Please look at the newest freeradius patch to find an example that might
be similar in aspell to remove this requirement.

greetings,

Florian La Roche


Comment 7 Eido Inoue 2003-05-21 16:38:02 UTC
The problem is moot now; the .la files have been removed.


Note You need to log in before you can comment on or make changes to this bug.