Bug 900378 (JBPAPP6-1326) - CDI beans with SET replication trigger are not replicating
Summary: CDI beans with SET replication trigger are not replicating
Status: CLOSED WONTFIX
Alias: JBPAPP6-1326
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: EAP 6.4.1
Assignee: Paul Ferraro
QA Contact: Jitka Kozana
Russell Dickenson
URL: http://jira.jboss.org/jira/browse/JBP...
Whiteboard: eap6_clustering
Keywords: Documentation
: 1150079 (view as bug list)
Depends On:
Blocks: JBPAPP6-1422 1150079
TreeView+ depends on / blocked
 
Reported: 2012-05-07 19:05 UTC by Radoslav Husar
Modified: 2015-05-28 09:26 UTC (History)
11 users (show)

(edit)
Due to a bug in the Weld component, the `setAttribute` method is not called correctly. This causes CDI beans with the `SET` replication trigger to fail to be replicated.

The workaround is to use the `SET_AND_NON_PRIMITIVE_GET` trigger for these beans. This will be fixed in a future release.
Clone Of:
(edit)
Last Closed: 2015-05-28 09:26:25 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP6-1326 Major Closed CDI beans with SET replication trigger are not replicating 2018-06-01 05:31 UTC
JBoss Issue Tracker WELD-1130 Major Resolved Weld does not call setAttribute for modified conversation and session scoped beans 2018-06-01 05:31 UTC

Description Radoslav Husar 2012-05-07 19:05:41 UTC
Affects: Release Notes
Workaround: Workaround Exists
Workaround Description: Use SET_AND_NON_PRIMITIVE_GET replication trigger (the default).
project_key: JBPAPP6

Please check if the use case is correct:

https://github.com/rhusar/clusterbench/blob/master/clusterbench-ee6-web/src/main/java/org/jboss/test/clusterbench/web/cdi/CdiServlet.java
https://github.com/rhusar/clusterbench/blob/master/clusterbench-ee6-web/src/main/java/org/jboss/test/clusterbench/web/cdi/SessionScopedCdiSerialBean.java

The methods are only called on the CDI-mananged bean, there is no interaction with the HTTP session itself. Should the replication trigger on the bean itself or is anything else required?

https://hudson.qa.jboss.com/hudson/job/eap-6x-failover-http-cdi-shutdown-repl-sync/2/

Comment 1 Rajesh Rajasekaran 2012-05-07 19:05:41 UTC
Link: Added: This issue Cloned from AS7-4726


Comment 2 Rajesh Rajasekaran 2012-05-07 19:06:24 UTC
Workflow: Removed: GIT Pull Request workflow  Added: jira
Security: Added: Public
Docs QE Status: Added: NEW


Comment 3 Rajesh Rajasekaran 2012-05-07 19:06:49 UTC
Labels: Removed: eap6_need_triage Added: eap6_clustering eap6_need_triage


Comment 4 Radoslav Husar 2012-05-08 19:21:19 UTC
Release Notes Docs Status: Added: Not Yet Documented


Comment 5 Rajesh Rajasekaran 2012-06-06 20:43:28 UTC
Link: Added: This issue is a dependency of JBPAPP-9290


Comment 6 Misty Stanley-Jones 2012-06-12 10:36:55 UTC
Release Notes Docs Status: Removed: Not Yet Documented Added: Documented as Known Issue
Release Notes Text: Added: Due to a bug in the Weld component, the <code>setAttribute</code> method is not called correctly. This causes CDI beans with the <code>SET</code> replication trigger to fail to be replicated. The workaround is to use the <code>SET_AND_NON_PRIMITIVE_GET</code> trigger for these beans. This will be fixed in a future release.
Affects: Added: Release Notes


Comment 7 Rajesh Rajasekaran 2012-07-11 19:36:26 UTC
Labels: Removed: eap6_clustering eap6_need_triage Added: eap601candidate eap6_clustering


Comment 8 Paul Ferraro 2012-08-09 20:17:58 UTC
Added workaround. Defer to EAP 6.1.

Comment 9 Paul Ferraro 2012-08-09 20:17:58 UTC
Workaround Description: Added: Use SET_AND_NON_PRIMITIVE_GET replication trigger (the default).
Workaround: Added: Workaround Exists


Comment 10 Dana Mison 2012-10-16 05:53:56 UTC
Writer: Added: mistysj


Comment 11 Dana Mison 2012-10-28 08:44:25 UTC
Release Notes Text: Removed: Due to a bug in the Weld component, the <code>setAttribute</code> method is not called correctly. This causes CDI beans with the <code>SET</code> replication trigger to fail to be replicated. The workaround is to use the <code>SET_AND_NON_PRIMITIVE_GET</code> trigger for these beans. This will be fixed in a future release. Added: Due to a bug in the Weld component, the `setAttribute` method is not called correctly. This causes CDI beans with the `SET` replication trigger to fail to be replicated. The workaround is to use the `SET_AND_NON_PRIMITIVE_GET` trigger for these beans. This will be fixed in a future release.


Comment 12 Anne-Louise Tangring 2012-11-13 20:54:53 UTC
Release Notes Docs Status: Removed: Documented as Known Issue 
Writer: Removed: mistysj 
Release Notes Text: Removed: Due to a bug in the Weld component, the `setAttribute` method is not called correctly. This causes CDI beans with the `SET` replication trigger to fail to be replicated. The workaround is to use the `SET_AND_NON_PRIMITIVE_GET` trigger for these beans. This will be fixed in a future release. 
Docs QE Status: Removed: NEW 


Comment 14 Paul Ferraro 2013-08-30 16:12:47 UTC
This will be addressed by new web session clustering implementation scheduled for 6.3.

Comment 16 Paul Ferraro 2013-11-20 14:19:29 UTC
I'm lowering the priority of this issue.  The SET replication trigger should only be used with care - so much that it won't exist in EAP7.  Nor is this the default behavior.

Comment 17 Paul Ferraro 2013-11-22 22:20:52 UTC
Setting target release to EAP7.  replication-trigger will be removed in this release.

Comment 18 Radoslav Husar 2013-12-06 12:26:48 UTC
Moving to documentation component: it should be permanently documented (as a note/warning/or so) that using Weld/CDI and having replication-trigger configured to SET is not supported in EAP 6.x releases.

Comment 20 Vimal Kansal 2014-10-07 15:25:33 UTC
*** Bug 1150079 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.