Bug 90038 - RFE: Please enable localization
Summary: RFE: Please enable localization
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Miloslav Trmac
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-01 15:02 UTC by Miloslav Trmac
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-07 18:34:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miloslav Trmac 2003-05-01 15:02:12 UTC
Please allow NLS support in e2fsprogs. It is as easy
as passing --enable-nls to configure and adding
the usual %find_lang stuff.

This does not create problems when /usr is not available,
fsck et al will just talk in English in that case.
Also, the static binary of e2fsck has about the same
size whether NLS is enabled or not.

I don't know whether this could case problems in case
e2fsprogs were compiled with dietlibc for some rescue
environment, dietlibc is not mentioned in the SRPM
though.

Thanks.

Comment 1 Miloslav Trmac 2003-05-05 11:48:09 UTC
In the following version of e2fsprogs, NLS will be enabled by default, so
passing --enable-nls to configure won't be needed.

Comment 2 Florian La Roche 2003-05-08 13:00:02 UTC
nls still seems to be pretty broken. I have managed to build a rpm, but have
not tested it yet: http://people.redhat.com/laroche/

greetings,

Florian La Roche


Comment 3 Miloslav Trmac 2003-05-09 12:50:43 UTC
Florian,
sorry about that file in POTFILES. I have actually sent an equivalent patch
upstream, but forgotten about it. 

I'll check that Czech translation in 1.34 (once it is released) works
correctly and close the bug then.
Thanks,
  Mirek.

Comment 4 Miloslav Trmac 2003-08-07 18:34:27 UTC
Works well enough. The Czech translation is fubared, but that's my fault and
I'll solve that upstream.



Note You need to log in before you can comment on or make changes to this bug.