Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 900548 (JBPAPP6-1469)

Summary: Server does not start after redeploying with jboss-cli.sh script
Product: [JBoss] JBoss Enterprise Application Platform 6 Reporter: Ondrej Chaloupka <ochaloup>
Component: Scripts and CommandsAssignee: Alexey Loubyansky <alex>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0.0CC: alex, jstefl, wurm.ch
Target Milestone: ---   
Target Release: TBD EAP 6   
Hardware: Unspecified   
OS: Unspecified   
URL: http://jira.jboss.org/jira/browse/JBPAPP6-1469
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-20 12:56:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Ondrej Chaloupka 2012-05-29 14:56:56 UTC
project_key: JBPAPP6

When I do following steps the server does not start.

1) Copy deployment jar to standalone/deployments folder
2) Start server
3) Do undeploy with jboss-cli.sh script
4) Do deploy with the script
5) Shutdown the server
6) Start the server

Server refuses to start with exception
{code}
16:53:49,452 INFO  [org.jboss.modules] JBoss Modules version 1.1.2.GA-redhat-1
16:53:49,884 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA-redhat-1
16:53:49,951 INFO  [org.jboss.as] JBAS015899: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) starting
16:53:52,063 ERROR [org.jboss.as.controller.management-operation] JBAS014613: Operation ("add") failed - address: ([("deployment" => "myejb.jar")]) - failure description: "JBAS014803: Duplicate resource [(\"deployment\" => \"myejb.jar\")]"
16:53:52,068 ERROR [org.jboss.as.server.deployment.scanner] JBAS014654: Composite operation was rolled back
16:53:52,069 FATAL [org.jboss.as.server] JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.
16:53:52,095 INFO  [org.jboss.as] JBAS015950: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) stopped in 16ms
{code}

For fixing is necessary to remove jar files from deployments folder and start the server. Then server starts correctly and the deployment can be repeated then.

Comment 1 Christoph Wurm 2012-10-11 12:54:15 UTC
I get exactly the same error, without redeploying in between. Just copy a jar to the deployments folder, start server and watch it crash. Any input would be greatly appreciated, having to repeat the deployment every time the server is started is a cumbersome workaround at best.

Unfortunately, the error message is lacking a crucial piece of information - exactly where the first instance of the allegedly duplicated jar resides. Adding that information to the message would be a tremendous benefit.

Comment 2 Alexey Loubyansky 2012-10-11 14:18:50 UTC
By design, you have to make choice: either you hot-deploy (copy to the deployments dir) an application and then it's not represented in the management model and not managed by the tools (no explicit deploy, undeploy, etc) or you use management tools, e.g. CLI, to manage deployments with explicit deploy, undeploy, etc.

Comment 3 Anne-Louise Tangring 2012-11-13 20:59:21 UTC
Docs QE Status: Removed: NEW 


Comment 4 Jan Stefl 2012-11-20 12:56:59 UTC
In described issue is mixed hot deploy and deployment with deploy tools.
But, by design, you cannot manage deployment of application by tools if was previously "hot deployed".