Bug 90061 - up2date - Segmentation fault
up2date - Segmentation fault
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
Depends On:
  Show dependency treegraph
Reported: 2003-05-01 17:01 EDT by Dan Dragut
Modified: 2007-04-18 12:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-22 11:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
up2date.strace.gz (95.85 KB, application/x-gzip-compressed)
2003-09-13 09:53 EDT, Dan Dragut
no flags Details

  None (edit)
Description Dan Dragut 2003-05-01 17:01:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; NetCaptor 7.0.2 

Description of problem:
Fresh install of RedHat 9 (Shrike), I tried to use up2date (command line) to 
register using an existing account and up2date dies with 'Segmentation fault'.

The same result when using 'rhnreg_ks'.

If you could provide me with some directions to solve this problem, I would 
greatly appreciate it.


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. up2date --register

Actual Results:  Segmentation fault

Additional info:
Comment 1 Scott Brenner 2003-05-02 03:59:18 EDT
I am having the exact same problem
Comment 2 Bob Anderson 2003-06-16 12:35:33 EDT
I have the same problem.  I have re-installed the system as desktop,  server,
etc. all with the same result.  If using gnome and clicking on the update alert
icon, you do not see an error message.  

I have had a weeks correspondence with RH support before being directed to
report it as a bug.

Net result, I am now registered on rhn but no registered system to update.  
Comment 3 Gerry Teudt 2003-07-11 23:26:24 EDT
I have this problem as well. I did a "Everything" install. Booted first time 
ok, then used the Up2date tool, and after reboot I could not start in Gnome. I 
receive about 10-15 segmentation errors for Gnome processes.

Any news/updates/recommendations? It looks like this was originally reported 
about 2 months ago.
Comment 4 Bill Marrs 2003-09-01 14:55:49 EDT
I was having this problem, but I was able to fix it by forcing a re-install of 

rpm --force -Uvh python-2.2.2-26.i386.rpm

I suspect that my python install got messed up.
Comment 5 Dan Dragut 2003-09-06 06:28:12 EDT

I have tried your suggestion, unfortunatelly it didn't solve my problem.
I must have some other package messed up...
Comment 6 Adrian Likins 2003-09-09 14:47:25 EDT
I need to know what command was invoked, and what the
output was on runs that segfault.

If it's possible to get the output of `strace -o /tmp/up2date.strace up2date`
for a run that segfaults, that would be helpful as well. 

I'd also verify the package involved:

rpm -V python rpm up2date up2date-gnome 
(attach the output if you want, but the main thing
to look for is either modified libs or bins)

Comment 7 Dan Dragut 2003-09-13 09:53:18 EDT
Created attachment 94473 [details]
Comment 8 Dan Dragut 2003-09-13 09:56:28 EDT
thanks for addressing the problem.

Please see the attached strace.

> rpm -V python rpm up2date up2date-gnome 
SM5....T c /etc/sysconfig/rhn/up2date
S.5....T c /etc/sysconfig/rhn/up2date-uuid
SM5....T   /usr/share/rhn/up2date_client/up2dateUtils.pyc
package up2date-gnome is not installed

> rpm -q python rpm up2date up2date-gnome
package up2date-gnome is not installed
Comment 9 Mark J Weixel 2003-10-05 14:07:10 EDT
Has anything been determined on this front?  I am having the same problem: up2date 
throws a Segmentation fault when I attempt to register a machine that has been newly 
built from scratch with Shrike.

Following Adrian's suggestions above, I verified the packages:

[root@dhcppc2 /tmp]# rpm -V python rpm up2date up2date-gnome
SM5....T c /etc/sysconfig/rhn/up2date
S.5....T c /etc/sysconfig/rhn/up2date-uuid
.M.....T   /usr/share/rhn/RHNS-CA-CERT
SM5....T   /usr/share/rhn/up2date_client/up2dateUtils.pyc

[root@dhcppc2 /tmp]# rpm -q python rpm up2date up2date-gnome

From what I can tell, everything is up to date (no pun intended).

Any insights would be greatly appreciated.

Comment 10 Ryan Johnson 2003-10-31 17:39:25 EST
I'm showing the exact same results as Dan and Mark.  Default 
installation of Red Hat Linux 9 with up2date version  

I know up2date was working flawlessly prior to the update to  After receiving the notification to update for the new SSL 
cert, the seg fault error started.

(I also tried to re-install python.)
Comment 11 John Thacker 2006-04-22 11:34:49 EDT
In any case, up2date is no longer shipped with Fedora Core; its functionality 
has been replaced by pup, found in the pirut package.  The only fixes 
likely to be made to up2date in RedHat Linux and earlier Fedora Core 
versions are security fixes by Fedora Legacy.  This does not seem to 
be a security bug, so I'm closing it.

If the problem is appropriate to RHEL and occurs to a user there, it 
can be filed as such.

Note You need to log in before you can comment on or make changes to this bug.