Bug 90064 - When ETH0 device is trusted, NFS mounts fail when RHL 7.3 clients try to mount them from /etc/fstab while booting.
When ETH0 device is trusted, NFS mounts fail when RHL 7.3 clients try to moun...
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2003-05-01 17:30 EDT by Joseph Tate
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-17 05:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/sysconfig/iptables (1.43 KB, text/plain)
2003-05-01 17:32 EDT, Joseph Tate
no flags Details

  None (edit)
Description Joseph Tate 2003-05-01 17:30:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When booting up RHL 7.3 machines which mount NFS shares exported from a RHL 9
machine.  The mount fails with "mount: RPC: Port mapper failure - RPC: Unable to
receive".  After the machines have booted, mount -a will succeed most of the
time.  When it doesn't succeed, restarting portmapper, or even pinging the NFS
server and retrying will usually succeed.  When it fails on subsequent mount -a
requests it fails with the same RPC port mapper error.

Running service iptables stop on the Server fixes the problem: 7.3 clients can
then mount the NFS mountpoints during bootup.  The port mapper request which
goes to the eth0 device, which is set up to be trusted, is being blocked.  No
lines appear in /var/log/messages on the NFS server machine which they normally
do if it receives a request.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Set up RHL 9 with a valid export on a machine which has a trusted ethernet
2. Add a line in /etc/fstab on a 7.3 client (haven't tried this on another 9
system) to mount the export set up on 1 over the trusted interface.
3. Mount the exported filesystem to ensure that it works.
4. Reboot the 7.3 machine.

Actual Results:  Mounting fails with the error:
    mount: RPC: Port mapper failure - RPC: Unable to receive
Dropping ipchains on the client machines had no effect on the boot up mount request.

Expected Results:  7.3 machine mounts the filesystem successfully.  This is the
result if ipchains is stopped on the NFS server.  

Additional info:

HW: Dell PowerEdge 2650, Dual Xeon 2.0 GHz, 512 MB RAM, 5 73 GB SCSI drives on
PERC 3 RAID 5 array.

SW: RHL 9 with all updates applied.

/etc/sysconfig/iptables will be attached.  I can also upload /etc/fstab (from
the clients) and /etc/exports (from the server) if desired.



I have tried a variety of things to get this to work.  Please refer to this post
on the Shrike mailing list for more information:
Comment 1 Joseph Tate 2003-05-01 17:32:15 EDT
Created attachment 91459 [details]

This is the promised /etc/sysconfig/iptables file.
Comment 2 Thomas Woerner 2004-08-17 05:31:03 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.