Bug 90078 - libsane-hpoj.so.1 library file is missing from the RPM package
libsane-hpoj.so.1 library file is missing from the RPM package
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: hpoj (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-01 23:04 EDT by Ignacio Goyret
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-02 04:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Goyret 2003-05-01 23:04:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The file libsane-hpoj.so is missing from the binary RPM hpoj-0.90-14.i386.rpm

# rpm -qil hpoj
Name        : hpoj                         Relocations: (not relocateable)
Version     : 0.90                              Vendor: Red Hat, Inc.
Release     : 14                            Build Date: Mon 24 Feb 2003 03:26:15
PM PST
Install Date: Sun 13 Apr 2003 12:31:02 PM PDT      Build Host: daffy.perf.redhat.com
Group       : System Environment/Daemons    Source RPM: hpoj-0.90-14.src.rpm
Size        : 695311                           License: GPL
Signature   : DSA/SHA1, Mon 24 Feb 2003 04:47:21 PM PST, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://hpoj.sourceforge.net
Summary     : HP OfficeJet low level driver infrastructure
Description :
The hpoj package adds support for most Hewlett-Packard OfficeJet, PSC, and
LaserJet all-in-one peripherals (also known as Multi-Function Peripherals
or MFPs), which can print, scan, copy, and (on some models) fax.
 
The HP-sponsored project is an work in progress, but printing, scanning,
and photo-card access are supported on most models, when either connected
to the parallel port or USB on a Linux workstation, or to a LAN with
selected HP JetDirect print servers.
/etc/rc.d/init.d/hpoj
/usr/bin/hpojip-test
/usr/bin/ptal-connect
/usr/bin/ptal-device
/usr/bin/ptal-devid
/usr/bin/ptal-hp
/usr/bin/ptal-pml
/usr/bin/ptal-print
/usr/lib/cups/backend/ptal
/usr/lib/libhpojip.so.0
/usr/lib/libhpojip.so.0.1
/usr/lib/libptal.so.0
/usr/lib/libptal.so.0.1
/usr/sbin/ptal-cups
/usr/sbin/ptal-init
/usr/sbin/ptal-mlcd
/usr/sbin/ptal-photod
/usr/sbin/ptal-printd
/usr/share/doc/hpoj-0.90
/usr/share/doc/hpoj-0.90/COPYING
/usr/share/doc/hpoj-0.90/LICENSE
/usr/share/doc/hpoj-0.90/LICENSE.OpenSSL
/usr/share/doc/hpoj-0.90/README
/usr/share/doc/hpoj-0.90/index.html
/usr/share/doc/hpoj-0.90/info-devname.html
/usr/share/doc/hpoj-0.90/info-pml-objects.html
/usr/share/doc/hpoj-0.90/info-protocols.html
/usr/share/doc/hpoj-0.90/libptal.html
/usr/share/doc/hpoj-0.90/libsane-hpoj.html
/usr/share/doc/hpoj-0.90/ptal-connect.html
/usr/share/doc/hpoj-0.90/ptal-device.html
/usr/share/doc/hpoj-0.90/ptal-devid.html
/usr/share/doc/hpoj-0.90/ptal-hp.html
/usr/share/doc/hpoj-0.90/ptal-init.html
/usr/share/doc/hpoj-0.90/ptal-mlcd.html
/usr/share/doc/hpoj-0.90/ptal-photod.html
/usr/share/doc/hpoj-0.90/ptal-pml.html
/usr/share/doc/hpoj-0.90/ptal-printd.html
/usr/share/doc/hpoj-0.90/setup-build-details.html
/usr/share/doc/hpoj-0.90/setup-build.html
/usr/share/doc/hpoj-0.90/setup-connect-details.html
/usr/share/doc/hpoj-0.90/setup-connect.html
/usr/share/doc/hpoj-0.90/setup-photo-details.html
/usr/share/doc/hpoj-0.90/setup-photo.html
/usr/share/doc/hpoj-0.90/setup-print-details.html
/usr/share/doc/hpoj-0.90/setup-print.html
/usr/share/doc/hpoj-0.90/setup-scan-details.html
/usr/share/doc/hpoj-0.90/setup-scan.html
/usr/share/doc/hpoj-0.90/xojpanel.html
#

Version-Release number of selected component (if applicable):
hpoj-0.90

How reproducible:
Always

Steps to Reproduce:
1. rpm -i hpoj
2. install an HP OfficeJet (may require a reboot so cups starts after hpoj --
see http://hpoj.sourceforge.net/hpoj-0.90/doc/setup-scan.html)
3. scanimage --list-devices

Actual Results:  on step #3, the results are:
[root@narf cups]# scanimage --list-devices
 
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[root@narf cups]#


Expected Results:  
It should have listed the device 'hpoj:mlc:usb:d145'


Additional info:

The problem is on the distribution, not on my system.
The library file libsane-hpoj.so.1 is missing from the RPM.
Comment 1 Tim Waugh 2003-05-02 04:15:20 EDT
You need to install the libsane-hpoj package.

Note You need to log in before you can comment on or make changes to this bug.