Bug 900849 (JBPAPP6-1341) - EAP6 CLI error when data is over 64k
Summary: EAP6 CLI error when data is over 64k
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: JBPAPP6-1341
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: TBD EAP 6
Assignee: Alexey Loubyansky
QA Contact:
URL: http://jira.jboss.org/jira/browse/JBP...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-04 21:18 UTC by dereed
Modified: 2014-05-27 01:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Any CLI command which returned a String that was over 65535 characters in length would fail with the following error: ---- Communication error: java.util.concurrent.ExecutionException: Operation failed ---- This was caused by the use of the `java.io.DataOutput.writeUTF()` method in the JBoss DMR library. This method throws a `UTFDataFormatException` if the string being processed is over 65535 characters in length. The JBoss DMR library was been updated to use an alternative technique to correctly process strings over this length. Any CLI command which returns a string over 65535 characters in length now performs as expected.
Clone Of:
Environment:
Last Closed: 2013-12-15 17:01:34 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP6-1341 Major Closed EAP6 CLI error when data is over 64k 2015-04-28 07:15:36 UTC

Description dereed 2012-09-04 21:18:05 UTC
Affects: Release Notes
project_key: JBPAPP6

Running a command from the CLI that generates too much data aborted with an error:

[standalone@localhost:9999 /] /core-service=service-container:dump-services
Communication error: java.util.concurrent.ExecutionException: Operation failed
[disconnected /]

The root cause is only logged at debug level in server.log:

16:12:15,887 DEBUG [org.jboss.as.protocol] (management-handler-thread - 7) active-op (1846420313) failed null: java.io.UTFDataFormatException: encoded string too long: 96453 bytes
    at java.io.DataOutputStream.writeUTF(DataOutputStream.java:347) [rt.jar:1.6.0_24]
    at java.io.DataOutputStream.writeUTF(DataOutputStream.java:306) [rt.jar:1.6.0_24]
    at org.jboss.as.protocol.mgmt.FlushableDataOutputImpl.writeUTF(FlushableDataOutputImpl.java:109) [jboss-as-protocol-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
    at org.jboss.dmr.StringModelValue.writeExternal(StringModelValue.java:46) [jboss-dmr-1.1.1.Final-redhat-1.jar:1.1.1.Final-redhat-1]
    at org.jboss.dmr.ModelNode.writeExternal(ModelNode.java:1476) [jboss-dmr-1.1.1.Final-redhat-1.jar:1.1.1.Final-redhat-1]
    at org.jboss.dmr.ObjectModelValue.writeExternal(ObjectModelValue.java:75) [jboss-dmr-1.1.1.Final-redhat-1.jar:1.1.1.Final-redhat-1]
    at org.jboss.dmr.ModelNode.writeExternal(ModelNode.java:1476) [jboss-dmr-1.1.1.Final-redhat-1.jar:1.1.1.Final-redhat-1]
    at org.jboss.as.controller.remote.ModelControllerClientOperationHandler$ExecuteRequestHandler$1.execute(ModelControllerClientOperationHandler.java:116) [jboss-as-controller-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
    at org.jboss.as.protocol.mgmt.AbstractMessageHandler$2$1.doExecute(AbstractMessageHandler.java:295) [jboss-as-protocol-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
    at org.jboss.as.protocol.mgmt.AbstractMessageHandler$AsyncTaskRunner.run(AbstractMessageHandler.java:512) [jboss-as-protocol-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_24]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_24]
    at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_24]
    at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.0.0.GA-redhat-1.jar:2.0.0.GA-redhat-1]

Comment 1 dereed 2012-09-04 21:22:12 UTC
Link: Added: This issue depends AS7-5491


Comment 2 Eamon 2012-10-03 04:40:39 UTC
Looking for some additional info here to prepare release notes:
Is this issue for a specific command or all commands?

Thanks,
Eamon

Comment 3 dereed 2012-10-03 15:57:33 UTC
Any command that returns a String that is over 64k bytes after converted to UTF-8.


Comment 4 Eamon 2012-10-04 00:49:12 UTC
Release Notes Text: Added: There is a known issue where any command that returns a String converted to UTF-8 that is over 64k is aborted with an error. The root cause of this is only logged at the debug level in server.log.


Comment 5 Eamon 2012-10-04 01:47:21 UTC
Release Notes Docs Status: Added: Documented as Known Issue


Comment 6 Alexey Loubyansky 2012-10-04 08:46:08 UTC
This is not exactly a CLI issue. It occurs in  org.jboss.dmr.StringModelValue.writeExternal(StringModelValue.java:46). It's a limitation of the DataOutput.writeUTF(String).

Comment 7 Eamon 2012-10-05 04:55:51 UTC
Thanks Alexey, I will update the release notes accordingly.

Comment 8 Eamon 2012-10-05 04:57:22 UTC
Release Notes Text: Removed: There is a known issue where any command that returns a String converted to UTF-8 that is over 64k is aborted with an error. The root cause of this is only logged at the debug level in server.log. Added: There is a known issue where any command that returns a String converted to UTF-8 that is over 64k is aborted with an error. The root cause of this is only logged at the debug level in server.log.
This issue occurs in org.jboss.dmr.StringModelValue.writeExternal(StringModelValue.java:46). It's a limitation of the DataOutput.writeUTF(String).
The issue is currently under investigation.


Comment 9 Dana Mison 2012-10-16 05:25:17 UTC
Writer: Added: elogue


Comment 10 Dana Mison 2012-10-29 00:54:03 UTC
Release Notes Text: Removed: There is a known issue where any command that returns a String converted to UTF-8 that is over 64k is aborted with an error. The root cause of this is only logged at the debug level in server.log.
This issue occurs in org.jboss.dmr.StringModelValue.writeExternal(StringModelValue.java:46). It's a limitation of the DataOutput.writeUTF(String).
The issue is currently under investigation. Added: There is a known issue where any command that returns a String converted to UTF-8 that is over 64k is aborted with an error. The root cause of this is only logged at the debug level in `server.log`. This issue occurs in `org.jboss.dmr.StringModelValue.writeExternal(StringModelValue.java:46)` and is a limitation of the `DataOutput.writeUTF(String)` method. The issue is currently under investigation.


Comment 11 Anne-Louise Tangring 2012-11-13 20:57:46 UTC
Release Notes Docs Status: Removed: Documented as Known Issue 
Writer: Removed: elogue 
Release Notes Text: Removed: There is a known issue where any command that returns a String converted to UTF-8 that is over 64k is aborted with an error. The root cause of this is only logged at the debug level in `server.log`. This issue occurs in `org.jboss.dmr.StringModelValue.writeExternal(StringModelValue.java:46)` and is a limitation of the `DataOutput.writeUTF(String)` method. The issue is currently under investigation. 
Docs QE Status: Removed: NEW 


Comment 13 Jakub Cechacek 2013-02-26 14:44:27 UTC
Verified for 6.1.DR4. Feel free to reopen this issue if needed.

Comment 14 Amit 2013-02-27 16:06:42 UTC
Hi Jakub,

Verified for 6.1.DR4 means issue is resolved in this version or still the issue exists.
I am still facing this issue in JBOSS EAP 6.0 for JSP which is working fine in other servers like Weblogic without issue. So looks like problem is only with JBOSS Server.

Thanks,
Amit

Comment 15 Jakub Cechacek 2013-02-27 17:18:27 UTC
It means that issue is resolved in 6.1.DR4.

Comment 16 Amit 2013-02-27 17:30:15 UTC
Thanks Jakub,

Can you please let me know its(6.1.DR4) JBOSS AS 7.2?
Is it available for download to test my JSP?

Thanks,
Amit

Comment 17 Amit 2013-02-28 14:53:51 UTC
Hi Jakub,

Please let me know the link to download this version so that I can test for my application.

Thanks,
Amit

Comment 18 Jakub Cechacek 2013-02-28 15:42:56 UTC
6.1 is an EAP version currently in development, it's based on AS 7.2 (unfortunately u will have to build it by yourself as it exist only in form of tag in git repository).

Comment 19 Amit 2013-02-28 16:03:38 UTC
Hi Jacub,

When this version is expected for release?
I am not sure about how to buld from the repository.
Also by any chance is there any patch available to fix this issue in EAP 6.0.

Thanks,
Amit

Comment 20 Jakub Cechacek 2013-02-28 16:32:13 UTC
I'm afraid that issue tracker is not the right place to ask such question, it would be much more suitable for Customer Portal.

Comment 24 Dana Mison 2013-05-07 03:00:17 UTC
Documented as fixed bug in EAP 6.1.0 release notes.


Note You need to log in before you can comment on or make changes to this bug.