Bug 90098 - Umlaut garbling between jpilot and handheld
Umlaut garbling between jpilot and handheld
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: jpilot (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-02 09:59 EDT by Patrick C. F. Ernzer
Modified: 2013-07-02 18:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 09:58:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2003-05-02 09:59:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Umlauts entered in jpilot show up as garbage on the Palm itself

Version-Release number of selected component (if applicable):
jpilot-0.99.2-11

How reproducible:
Always

Steps to Reproduce:
1. enter an address with a city of 'K"o�ln'
2. sync
3. look up the entry in the Palm
    

Actual Results:  the �"o shows up as: captital A with a tilde on top plus the
mirrored P with two bars

Expected Results:  "o

Additional info:

correcting the town name on the Palm makes that bit of data (i.e. not the whole
record) display blank in jpilot after another sync

The Palm is a Vx
Palm OS v.3.5.3

the O-Umlaut is written as "o because all the O-Umlaut disappeared when I opened
the bugzilla entry form

FWIW: I generate my umlauts with a compose key as I do not have a German keyboard.

And, as expected, I get similar junk with french accents as well
Comment 1 Ngo Than 2003-05-07 12:39:55 EDT
Patrick, could you please try jpilot-0.99.5-2 in rawhide. It should fix UTF8 issue.
Comment 2 Patrick C. F. Ernzer 2003-05-08 03:33:29 EDT
The problem is different now:

I cannot enter Umlauts in jpilot jpilot-0.99.5-2, COMPOSE-"-a now yields "a
(really quotes followed by a)

entering an umlaut in a gnome-terminal and pasting it into jpilot yields a
capital A with a tilde followed by a circle with 4 extensions

An existing record (a memo) now shows the Umlauts in the details field of
jpilot, but the word ends before the umlaut in the overview field

Entering a new memo in the Pilot shows the same behaviour as the existing memo.

Drop by my desk if these explanations are not understandble (it's still early
for me) I'll show you.

FWIW: $ echo $LANG
en_US.UTF-8

setting LANG to C yields exactly the same results
Comment 3 Patrick C. F. Ernzer 2003-05-08 03:39:19 EDT
correction, with LANG=C everything but pasting from gnome-terminal is identical.

pasting an A-Umlaut from gnome-terminal now yields \x{00E4} (no matter is that
terminal has LANG set to en_US.UTF-8 or C
Comment 4 Jindrich Novy 2004-09-02 07:52:44 EDT
Patrick, is there the same problem with jpilot-0.99.7 ?
Comment 5 Patrick C. F. Ernzer 2004-09-02 09:58:52 EDT
Jindrich,

no, in 0.99-7 on FC2, with $LANG at 'en_US.UTF-8' and jpilot set to
'Host UTF-8 <-> Palm Windows1250(EE)' the problem is no longer
reproducible.

Closing bug.

Note You need to log in before you can comment on or make changes to this bug.