Bug 900988 (JBPAPP6-1258) - RemoteCallWhileShuttingDownTestCase and JBWS3207TestCase fail consistently on Windows due to ConnectionTimeOut to port 9999
Summary: RemoteCallWhileShuttingDownTestCase and JBWS3207TestCase fail consistently on...
Keywords:
Status: CLOSED NOTABUG
Alias: JBPAPP6-1258
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Pending
: EAP 6.2.0
Assignee: Tomaz Cerar
QA Contact: Pavel Jelinek
URL: http://jira.jboss.org/jira/browse/JBP...
Whiteboard:
Depends On:
Blocks: JBPAPP6-1179
TreeView+ depends on / blocked
 
Reported: 2012-10-03 15:04 UTC by Madhumita Sadhukhan
Modified: 2014-10-25 12:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-28 17:59:19 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker AS7-5132 0 Major Resolved Connection timeout to local port 9999 with clustered AS 7.1.1.Final 2016-05-20 09:29:09 UTC
Red Hat Issue Tracker AS7-5350 0 Major Resolved CliArgumentsTestCase.testWrongControler always fails on windows 2016-05-20 09:29:09 UTC
Red Hat Issue Tracker JBPAPP6-1258 0 Major Closed RemoteCallWhileShuttingDownTestCase and JBWS3207TestCase fail consistently on Windows due to ConnectionTimeOut to port 9... 2016-05-20 09:29:09 UTC

Description Madhumita Sadhukhan 2012-10-03 15:04:31 UTC
project_key: JBPAPP6

These two tests consistently on Windows even when run on fast machines.

I think stacktrace is similar to AS7-5132
We might need  higher timeout value for Windows.

Hudson Job:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-Windows-matrix-OracleJDK6/jdk=java16_default,label=dev101-W2k8r2-x86_64/lastCompletedBuild/testReport/

Stacktrace:

Error Message

java.net.ConnectException: JBAS012144: Could not connect to remote://dev101:9999. The connection timed out

Stacktrace

java.io.IOException: java.net.ConnectException: JBAS012144: Could not connect to remote://dev101:9999. The connection timed out
	at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeForResult(AbstractModelControllerClient.java:129)
	at org.jboss.as.controller.client.impl.AbstractModelControllerClient.execute(AbstractModelControllerClient.java:71)
	at org.jboss.as.test.integration.management.ManagementOperations.executeOperation(ManagementOperations.java:54)
	at org.jboss.as.test.integration.management.ManagementOperations.executeOperation(ManagementOperations.java:36)..........................................................................................................................
Caused by: java.net.ConnectException: JBAS012144: Could not connect to remote://dev101:9999. The connection timed out
	at org.jboss.as.protocol.ProtocolConnectionUtils.connectSync(ProtocolConnectionUtils.java:120)
	at org.jboss.as.protocol.ProtocolConnectionManager$EstablishingConnection.connect(ProtocolConnectionManager.java:247)

Comment 1 Madhumita Sadhukhan 2012-10-03 15:04:58 UTC
Link: Added: This issue relates to AS7-5132


Comment 2 Madhumita Sadhukhan 2012-10-29 10:17:07 UTC
Assigning it to you as you have been looking into windows failures for 6.0.1

Comment 3 Madhumita Sadhukhan 2012-10-29 10:18:43 UTC
Link: Added: This issue is a dependency of JBPAPP-8860


Comment 4 Tomaz Cerar 2012-10-29 13:14:01 UTC
Link: Added: This issue relates to AS7-5350


Comment 5 Anne-Louise Tangring 2012-11-13 20:53:10 UTC
Docs QE Status: Removed: NEW 


Comment 6 Pavel Jelinek 2013-08-22 14:52:26 UTC
The connection timed out issue for RemoteCallWhileShuttingDownTestCase still remains on both Windows and Solaris 11 for EAP 6.1.1.

Comment 7 Paul Ferraro 2013-08-30 16:00:51 UTC
Removing Clustering component.  The tests in question are not clustering tests.

Comment 8 Tomaz Cerar 2013-09-20 17:49:19 UTC
this test is working 
current stats for it on lightning:

545 runs / 2 failures / 0 ignored Success rate: 99.6% 

see http://lightning.mw.lab.eng.bos.redhat.com/project.html?projectId=EAP&testNameId=3339343782755427496&tab=testDetails 
for more details

Comment 10 Pavel Jelinek 2013-10-07 08:39:53 UTC
org.jboss.as.test.integration.ws.tools.jbws3207.JBWS3207TestCase passes now but 
org.jboss.as.test.manualmode.ejb.shutdown.RemoteCallWhileShuttingDownTestCase fails due to the timeout for EAP 6.2.0 ER3 consistently on Windows on mw Jenkins, e.g.:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-61-as-testsuite-Win-matrix-OracleJDK6/56/jdk=java16_default,label_exp=w2k8%26%26x86/testReport/org.jboss.as.test.manualmode.ejb.shutdown/RemoteCallWhileShuttingDownTestCase/testServerShutdownRemoteCall/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-61-as-testsuite-Win-matrix-OracleJDK6/57/jdk=java16_default,label_exp=w2k8%26%26x86/testReport/org.jboss.as.test.manualmode.ejb.shutdown/RemoteCallWhileShuttingDownTestCase/testServerShutdownRemoteCall/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-61-as-testsuite-Win-matrix-OracleJDK6/55/jdk=java16_default,label_exp=w2k8%26%26x86_64/testReport/org.jboss.as.test.manualmode.ejb.shutdown/RemoteCallWhileShuttingDownTestCase/testServerShutdownRemoteCall/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-61-as-testsuite-Win-matrix-OracleJDK6/56/jdk=java16_default,label_exp=w2k8%26%26x86_64/testReport/org.jboss.as.test.manualmode.ejb.shutdown/RemoteCallWhileShuttingDownTestCase/testServerShutdownRemoteCall/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-61-as-testsuite-Win-matrix-OracleJDK6/57/jdk=java16_default,label_exp=w2k8%26%26x86_64/testReport/org.jboss.as.test.manualmode.ejb.shutdown/RemoteCallWhileShuttingDownTestCase/testServerShutdownRemoteCall/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-61-as-testsuite-Win-matrix-OracleJDK6/58/jdk=java16_default,label_exp=w2k8%26%26x86_64/testReport/org.jboss.as.test.manualmode.ejb.shutdown/RemoteCallWhileShuttingDownTestCase/testServerShutdownRemoteCall/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-61-as-testsuite-Win-matrix-OracleJDK6/58/jdk=java16_default,label_exp=w2k8r2/testReport/org.jboss.as.test.manualmode.ejb.shutdown/RemoteCallWhileShuttingDownTestCase/testServerShutdownRemoteCall/


Note You need to log in before you can comment on or make changes to this bug.