Bug 901022 (JBPAPP6-1320) - EJBCLIENT000028: No EJB receiver contexts available in cluster
Summary: EJBCLIENT000028: No EJB receiver contexts available in cluster
Status: CLOSED NOTABUG
Alias: JBPAPP6-1320
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering, EJB
Version: 6.1.1,6.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: EAP 6.3.0
Assignee: Paul Ferraro
QA Contact: Jitka Kozana
URL: http://jira.jboss.org/jira/browse/JBP...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-06 07:12 UTC by Jitka Kozana
Modified: 2015-01-26 11:47 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-02-10 19:21:04 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP6-1320 Major Closed EJBCLIENT000028: No EJB receiver contexts available in cluster 2015-09-08 14:57:53 UTC

Description Jitka Kozana 2012-10-06 07:12:27 UTC
project_key: JBPAPP6

after network restoration, we saw client getting stale data
{code}
2012/10/05 08:39:52:617 EDT [WARN ][Runner - 329] SFCORE_LOG - Error sampling data:  <org.jboss.smartfrog.loaddriver.RequestProcessingException: Response serial does not match. Expected: 54, received: 53, runner: 329.>
{code}
and later
{code}
2012/10/05 08:41:54:495 EDT [ERROR][Runner - 129] HOST perf17.mw.lab.eng.bos.redhat.com:rootProcess:c - Error getting response. <java.lang.IllegalStateException: EJBCLIENT000028: No EJB receiver contexts available in cluster ejb>
        java.lang.IllegalStateException: EJBCLIENT000028: No EJB receiver contexts available in cluster ejb
	at org.jboss.ejb.client.EJBClientContext.requireClusterEJBReceiverContext(EJBClientContext.java:754)
	at org.jboss.ejb.client.ReceiverInterceptor.handleInvocation(ReceiverInterceptor.java:84)
	at org.jboss.ejb.client.EJBClientInvocationContext.sendRequest(EJBClientInvocationContext.java:183)
	at org.jboss.ejb.client.EJBInvocationHandler.doInvoke(EJBInvocationHandler.java:136)
	at org.jboss.ejb.client.EJBInvocationHandler.doInvoke(EJBInvocationHandler.java:121)
	at org.jboss.ejb.client.EJBInvocationHandler.invoke(EJBInvocationHandler.java:104)
	at $Proxy0.getSerialAndIncrement(Unknown Source)
	at org.jboss.smartfrog.clustering.ejb3.StatefulSBProcessorFactoryImpl$EJB3RequestProcessor.processRequest(StatefulSBProcessorFactoryImpl.java:75)
	at org.jboss.smartfrog.loaddriver.CompoundRequestProcessorFactoryImpl$CompoundRequestProcessor.processRequest(CompoundRequestProcessorFactoryImpl.java:52)
	at org.jboss.smartfrog.loaddriver.Runner.run(Runner.java:87)
	at java.lang.Thread.run(Thread.java:662)
{code}
Cannot find anything on the server side.
Link to job:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Failover/job/eap-6x-failover-ejb-ejbremote-netDown-repl-async/4/

Comment 1 Anne-Louise Tangring 2012-11-13 20:54:52 UTC
Docs QE Status: Removed: NEW 


Comment 6 Richard Janík 2013-12-10 10:27:18 UTC
Just an update: this was seen in 6.2.0.GA as well.
Link to sample build:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-failover-ejb-ejbremote-netDown-repl-async/31/

Link to client log (it's a ~180MB file, I suggest to wget just a part of it, first exception is on line ~1500):

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-failover-ejb-ejbremote-netDown-repl-async/31/console-perf17/consoleText

Comment 7 Paul Ferraro 2014-02-10 19:21:04 UTC
The "netDown" scenario should not be used during functional testing.  EAP will never handle this scenario perfectly.  The attached stacktrace can be expected following this scenario.

Comment 8 Scott Mumford 2014-04-23 02:47:01 UTC
Marking for exclusion from Release Notes documentation as not a bug

Comment 9 Thiru Raveendran 2015-01-26 11:47:18 UTC
Hi,

I get this error in EAP 6.2. 

Can you please help me how to fix this?


Note You need to log in before you can comment on or make changes to this bug.