Bug 901332 - glustershd and nfs services are not restarted during an upgrade
glustershd and nfs services are not restarted during an upgrade
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 19:42 EST by Joe Julian
Modified: 2014-12-14 14:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-14 14:40:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2013-01-17 19:42:23 EST
Description of problem:
Neither the self-heal nor nfs daemons are restarted during an rpm update. 

Since glustershd is not a user-facing daemon, I recommend adding it to the stop and start functions in the glusterd init process. The pid is in /var/lib/glusterd/glustershd/run/glustershd.pid. Kill it in stop only if the process name is glusterfs. Start is handled by glusterd so no changes to start() are necessary.

gluster-nfs should have it's own init script since it's user-facing. A start could, unless there's a better way to do it, just restart glusterd. The stop would kill the process whose pid is in /var/lib/glusterd/nfs/run/nfs.pid if the name is glusterfs.
Comment 1 Niels de Vos 2014-11-27 09:54:06 EST
The version that this bug has been reported against, does not get any updates from the Gluster Community anymore. Please verify if this report is still valid against a current (3.4, 3.5 or 3.6) release and update the version, or close this bug.

If there has been no update before 9 December 2014, this bug will get automatocally closed.

Note You need to log in before you can comment on or make changes to this bug.