Bug 90136 - emacs font-lock error on java file
emacs font-lock error on java file
Status: CLOSED DUPLICATE of bug 90135
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 01:07 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-05-03 01:07:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
$ cat Test1.java
 
public class Test1 {
 
  public static void main(String[] args) {
    System.getProperties().list(System.out);
  }
 
}

$ emacs -nw -q --no-site-file \
--eval '(global-font-lock-mode t)' \
--eval '(setq debug-on-error t)' Test1.java

This results in the error:
Debugger entered--Lisp error: (wrong-type-argument integer-or-marker-p nil)
  goto-char(nil)
  eval((goto-char (match-beginning 4)))
  font-lock-fontify-keywords-region(1 119 nil)
  font-lock-default-fontify-region(1 119 nil)
  font-lock-fontify-region(1 119)
  run-hook-with-args(font-lock-fontify-region 1 119)
  jit-lock-fontify-now(1 501)
  jit-lock-function(1)

This seems to happen with any java file. (the above file is just a simple
sample)  The -nw option is not necessary, I just specify it to make sure that
the problem is not due to some X font problem.  This problem resulted after an
upgrade from rh 8.0 to rh 9.

Version-Release number of selected component (if applicable):
emacs-21.2-33

How reproducible:
Always
Comment 1 Need Real Name 2003-05-03 02:08:16 EDT
Whoops.  I accidentally did a double commit.

*** This bug has been marked as a duplicate of 90135 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.