Bug 90141 - System freeze when choosing Pulsar (GL) screensaver
System freeze when choosing Pulsar (GL) screensaver
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 05:31 EDT by Albert Tumanov
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 18:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Tumanov 2003-05-03 05:31:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
System freeze when choosing Pulsar (GL) screensaver.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Using KDE Control Center, go to Appearance % Themes, Screen Saver.
Then select the Pulsar (GL) screensaver from the list.


Actual Results:  System immediately freeze (without even pressing Test button),
with mouse cursor still moving,
but clicks not responding. Keyboard is also frozen, Ctrl-Alt-Backspace not
working. Only the hardware reset is possible.

Additional info:

This screensaver seems to be the only one that causes problems.
All other GL-screensavers work, and can be seen fullscreen using the Test button.

Used video card: ATI Radeon 64 VIVO.

XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20-3bigmem i686 [ELF]
Build Date: 27 February 2003
Build Host: porky.devel.redhat.com

        Before reporting problems, check http://www.XFree86.Org/
        to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.20-8 (bhcompile@porky.devel.redhat.com) (gcc
version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13 17:54:28 EST 2003
Comment 1 Albert Tumanov 2003-06-21 13:18:11 EDT
The problem does not occur after installing XFree86-4.3.0-15.1 packages from 
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/
Pulsar (GL) screensaver works without problem.
Comment 2 Mike A. Harris 2004-09-29 18:10:19 EDT
Thanks for the update.

Setting bug status to "ERRATA" version 4.3.0-2.90.55 which is based
off of the rawhide 4.3.0-55 package at the time, and would also
contain the same fix present in rawhide.




Note You need to log in before you can comment on or make changes to this bug.