Bug 90142 - RPM hangs after installing additional kernel with --force
RPM hangs after installing additional kernel with --force
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 07:24 EDT by benno
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-05 10:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description benno 2003-05-03 07:24:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I'm using Red Hat 9 and I unfortunatelty discovered that the "rpm hangs" bug of
Red Hat 8 is still not fixed.

For example today I tried to install a second kernel (which is older than the
2.4.20 shipped with RH9) and I used the rpm -i --force  since without the
--force option rpm does not let me install the kernel because it says the kernel
is older than the one installed.
The install proceeds and at 100% it hangs. The files get all installed
(/lib/modules/my_kernel_version/ etc, but since rpm hangs I have to kill -9 it
and rebuild the db with rpm --rebuilddb.
After that operation, doing a rpm -qa, the kernel does not show up as installed
but the files are here.

My question: is this rpm bug really that obscure that none of the RPM experts
are able to find it ? Any light in sight ? I think a broken RPM system is really
bad publicity for RH especially because the last two shipping distros (RH8 and
RH9) ship with the broken RPM system.

Perhaps reverting to a previous version of RPM would be wise until bugs are
fixed ? I'm a long time Red Hat user and up to RH 7.3 RPM worked flawlessly.
Other distros using RPM use older versions (eg Mandrake uses RPM 4.0.4) and I do
not hear about RPM hangs from these users.

I run a linux community site and complaints about this annoying RPM bug in RH8
and RH9 are getting louder and louder.
I experience RPM hangs almost daily and I'm sure tousands of other RH users do
experience the same annoying behavious with most of newbies unable to fix it
since they do not know how to do it. 

Sorry for being a bit polemical and less technical but I think this is one of
the most severe bugs I have seen in Red Hat in years and if not fixed shortly,
damage the reputation of Red Hat of producing a solid and stable distro since
the RPM system is one of the pillars making up this distro.

I'm no RPM expert and do not know if it is possible, but again, how to revert to
an older version of RPM until the bug is fixed ? I think most Red Hat users
would prefer a more stable RPM system with less features rather than using a
flaky bleeding-edge version.

Please let me know.

cheers,
Benno

http://www.linuxdesktop.it

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh --force kernel-older_version_than_installed
2.
3.
    

Actual Results:  installl progress meter goes up to 100% and then hangs
files get installed, but after rebuilding the RPM DB, RPM does not show up in
the installed rpm package list

Expected Results:  normal rpm installation with no hangs


Additional info:
Comment 1 Jeff Johnson 2003-05-05 10:20:31 EDT
Yup, rpm-4.2-0.69 still leaves stale locks on abnormal
exits.

Fixed in rpm-4.2-1 packages at ftp://ftp.rpm.org/pub/rpm/test-4.2

Note You need to log in before you can comment on or make changes to this bug.