Bug 90143 - [RFE] ignore-packages / select-all, select-deselect multiple package
[RFE] ignore-packages / select-all, select-deselect multiple package
Status: CLOSED DUPLICATE of bug 165317
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Beth Nackashi
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-05-03 07:33 EDT by shrek-m
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-08 23:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description shrek-m 2003-05-03 07:33:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.0.2) Gecko/20030208

Description of problem:
it would be great if i could
  select/deselect multiple-packages [shift], [ctrl]
to ignore for update

install a full rhl 9  in 2004
or now rhl 8.0
a lot of packages which i would not update all together,
but i will get the info about new erratas

for the first time:
  ignore all
in several sessions:
  select a few packages for update
  check, all ok
  select a few packages for update
  check, all ok

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install a full system in 2004
2. or install now a full rhl 8.0
3. try to ignore some/all packages

Actual Results:  you get a "tendovaginitis"
by clicking for ignoring every package

Expected Results:  select all
select/deselect with [shift], [ctrl]

Additional info:

not sure,
but if you startx for a new user
all ignored packages are shown as not updated
you get once again a "tendovaginitis"
Comment 1 Robin Norwood 2005-10-08 23:36:00 EDT
bug #165317 addresses making 'shift' and 'ctrl' work as one would expect in a
multi-select box, and 'select all' is 'click first item, scroll to bottom, hold
down shift, click last item'.

'select all' doesn't work for the current UI because, well, which list does
'select all' apply to?  The left one or the right one?  We could have instead
'ignore all' and...and... 'pay attention to all', but I think the shift/ctrl
solution is good enough.

Closing as a dupe of 165317, since that bug includes a patch.

*** This bug has been marked as a duplicate of 165317 ***

Note You need to log in before you can comment on or make changes to this bug.