Bug 901443 - engine-setup should prompt for application mode
engine-setup should prompt for application mode
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2
Assigned To: Aravinda VK
gluster
:
Depends On:
Blocks: ovirt-3.2-release
  Show dependency treegraph
 
Reported: 2013-01-18 03:29 EST by Shireesh
Modified: 2013-07-25 16:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 16:47:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11801 None None None Never
oVirt gerrit 9991 None None None Never

  None (edit)
Description Shireesh 2013-01-18 03:29:22 EST
The engine-setup script should prompt the user to choose an application mode

- virt [Manage virtualization only]
- gluster [Manage gluster storage only]
- both [Manage virtualization and gluster storage]

Based on user's selection, following should happen:

- Set the vdc option ApplicationMode appropriately
- In case of gluster-only mode, do not prompt the user for DC storage type, and ISO path, as these are not relevant for gluster.

Note You need to log in before you can comment on or make changes to this bug.