Bug 901454 - Review Request: nodejs-source-map - Generates and consumes source maps
Summary: Review Request: nodejs-source-map - Generates and consumes source maps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jamie Nguyen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 901451
Blocks: 894725
TreeView+ depends on / blocked
 
Reported: 2013-01-18 09:01 UTC by T.C. Hollingsworth
Modified: 2013-04-05 23:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-16 02:39:50 UTC
jamielinux: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description T.C. Hollingsworth 2013-01-18 09:01:26 UTC
Spec: http://patches.fedorapeople.org/npm/nodejs-source-map.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-source-map-0.1.8-1.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4880063
FAS username: patches

Generates and consumes source maps

This package is part of the tap stack used to test many Node.js modules.

Please use nodejs-0.6.5-9 or later when building or using this package.

Comment 1 T.C. Hollingsworth 2013-01-18 09:13:55 UTC
This package would BuildRequire npm(dryice) to build the browser, but that requires npm(uglify-js), which would create a dependency loop in Bugzilla.  It doesn't like that.

Comment 2 Jamie Nguyen 2013-02-08 10:03:28 UTC
"License: FIXME" should be changed to BSD.
"URL: FIXME.now" should be changed to the proper URL.

LICENSE and README.md shouldn't be on line 26 but instead included in %doc.

Comment 3 Jamie Nguyen 2013-02-08 10:04:54 UTC
Oh false alarm... looks like you already did that but you only updated the SPEC not the SRPM.

Comment 4 T.C. Hollingsworth 2013-02-09 00:00:31 UTC
Sorry about that.  I've synced the two and fixed a minor bug in the original spec file.

Spec: http://patches.fedorapeople.org/npm/nodejs-source-map.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-source-map-0.1.8-2.fc18.src.rpm

No scratch build because the BuildRequires aren't in Fedora yet.

Comment 5 Jamie Nguyen 2013-02-09 00:06:30 UTC
I think the Name tag be nodejs-source-map not source-map?

Comment 6 Jamie Nguyen 2013-02-09 00:07:02 UTC
Damn it false alarm again, browser cache had the old version!

Comment 7 Jamie Nguyen 2013-02-09 22:39:59 UTC
This line:

  BuildRequires:  nodejs(amdefine)

Needs to be changed to:

  BuildRequires:  npm(amdefine)

Comment 8 Jamie Nguyen 2013-02-09 22:58:54 UTC
I created an SRPM with the fixed BuildRequires as mentioned in comment #7, but building gives this error:

DEBUG: Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.1EwO53
DEBUG: + umask 022
DEBUG: + cd /builddir/build/BUILD
DEBUG: + cd package
DEBUG: + /usr/bin/node test/run-tests.js
DEBUG: module.js:340
DEBUG:     throw err;
DEBUG:           ^
DEBUG: Error: Cannot find module 'amdefine'
DEBUG:     at Function.Module._resolveFilename (module.js:338:15)
DEBUG:     at Function.Module._load (module.js:280:25)
DEBUG:     at Module.require (module.js:362:17)
DEBUG:     at require (module.js:378:17)
DEBUG:     at Object.<anonymous> (/builddir/build/BUILD/package/test/source-map/util.js:8:18)
DEBUG:     at Module._compile (module.js:454:26)
DEBUG:     at Object.Module._extensions..js (module.js:472:10)
DEBUG:     at Module.load (module.js:356:32)
DEBUG:     at Function.Module._load (module.js:312:12)
DEBUG:     at Module.require (module.js:362:17)
DEBUG: error: Bad exit status from /var/tmp/rpm-tmp.1EwO53 (%check)
DEBUG:     Bad exit status from /var/tmp/rpm-tmp.1EwO53 (%check)

Comment 10 Jamie Nguyen 2013-02-11 22:53:21 UTC
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. No licenses
     found. Please check the source files for licenses manually.
See: http://fedoraproject.org/wiki/Packaging/LicensingGuidelines#ValidLicenseShortNames


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[x]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[-]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in %package -n
     source-map
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. No licenses
     found. Please check the source files for licenses manually.
[x]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[-]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 20480 bytes in 2 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[ ]: Buildroot is not present
     Note: Buildroot: present but not needed
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[ ]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX tarball generation or download is documented.
[!]: SourceX / PatchY prefixed with %{name}.
     Note: Source0 (source-map-0.1.8.tgz)
[x]: SourceX is a working URL.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[ ]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: nodejs-source-map-0.1.8-3.fc18.noarch.rpm
          nodejs-source-map-0.1.8-3.fc18.src.rpm
nodejs-source-map.noarch: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-source-map.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
nodejs-source-map.noarch: W: only-non-binary-in-usr-lib
nodejs-source-map.noarch: W: dangling-symlink /usr/lib/node_modules/source-map/node_modules/amdefine /usr/lib/node_modules/amdefine
nodejs-source-map.src: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-source-map.src: W: spelling-error %description -l en_US js -> dis, ks, j
2 packages and 0 specfiles checked; 0 errors, 6 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint nodejs-source-map
nodejs-source-map.noarch: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-source-map.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
nodejs-source-map.noarch: W: only-non-binary-in-usr-lib
nodejs-source-map.noarch: W: dangling-symlink /usr/lib/node_modules/source-map/node_modules/amdefine /usr/lib/node_modules/amdefine
1 packages and 0 specfiles checked; 0 errors, 4 warnings.
# echo 'rpmlint-done:'



Requires
--------
nodejs-source-map-0.1.8-3.fc18.noarch.rpm (rpmlib, GLIBC filtered):
    
    nodejs(engine) >= 0.8.0
    npm(amdefine) >= 0.0.4



Provides
--------
nodejs-source-map-0.1.8-3.fc18.noarch.rpm:
    
    nodejs-source-map = 0.1.8-3.fc18
    npm(source-map) = 0.1.8



MD5-sum check
-------------
http://registry.npmjs.org/source-map/-/source-map-0.1.8.tgz :
  CHECKSUM(SHA256) this package     : 1745dd3ca3ec0cabc847f6c211215700b2eaa1e32df45018fcb9bdf6d4ce5916
  CHECKSUM(SHA256) upstream package : 1745dd3ca3ec0cabc847f6c211215700b2eaa1e32df45018fcb9bdf6d4ce5916


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-18-x86_64
Command line :/bin/fedora-review --rpm-spec -n nodejs-source-map-0.1.8-3.fc18.src.rpm

Comment 11 Jamie Nguyen 2013-02-11 22:53:48 UTC
Review approved!

Comment 12 T.C. Hollingsworth 2013-02-12 07:02:33 UTC
New Package SCM Request
=======================
Package Name: nodejs-source-map
Short Description: Generates and consumes source maps
Owners: patches
Branches: f18 el6
InitialCC:

Comment 13 Gwyn Ciesla 2013-02-13 00:38:57 UTC
Git done (by process-git-requests).

Comment 14 Fedora Update System 2013-02-13 04:27:36 UTC
nodejs-amdefine-0.0.4-1.fc18,nodejs-buffer-equal-0.0.0-1.fc18,nodejs-charm-0.1.0-1.fc18,nodejs-deep-equal-0.0.0-2.fc18,nodejs-optimist-0.3.5-1.fc18,nodejs-source-map-0.1.8-3.fc18,nodejs-traverse-0.6.3-2.fc18,nodejs-wordwrap-0.0.2-2.fc18,nodejs-yamlish-0.0.5-1.fc18,uglify-js-2.2.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nodejs-amdefine-0.0.4-1.fc18,nodejs-buffer-equal-0.0.0-1.fc18,nodejs-charm-0.1.0-1.fc18,nodejs-deep-equal-0.0.0-2.fc18,nodejs-optimist-0.3.5-1.fc18,nodejs-source-map-0.1.8-3.fc18,nodejs-traverse-0.6.3-2.fc18,nodejs-wordwrap-0.0.2-2.fc18,nodejs-yamlish-0.0.5-1.fc18,uglify-js-2.2.4-1.fc18

Comment 15 Fedora Update System 2013-02-16 01:24:31 UTC
nodejs-amdefine-0.0.4-1.fc18, nodejs-buffer-equal-0.0.0-1.fc18, nodejs-charm-0.1.0-1.fc18, nodejs-deep-equal-0.0.0-2.fc18, nodejs-optimist-0.3.5-1.fc18, nodejs-source-map-0.1.8-3.fc18, nodejs-traverse-0.6.3-2.fc18, nodejs-wordwrap-0.0.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-difflet-0.2.3-2.fc18, uglify-js1-1.3.4-1.fc18 has been pushed to the Fedora 18 testing repository.

Comment 16 Fedora Update System 2013-04-05 23:06:10 UTC
nodejs-amdefine-0.0.4-1.fc18, nodejs-buffer-equal-0.0.0-1.fc18, nodejs-charm-0.1.0-1.fc18, nodejs-deep-equal-0.0.0-2.fc18, nodejs-optimist-0.3.5-1.fc18, nodejs-source-map-0.1.8-3.fc18, nodejs-traverse-0.6.3-2.fc18, nodejs-wordwrap-0.0.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-difflet-0.2.3-2.fc18, uglify-js1-1.3.4-1.fc18 has been pushed to the Fedora 18 stable repository.


Note You need to log in before you can comment on or make changes to this bug.