Bug 90147 - International char wrong when exporting to Word95
Summary: International char wrong when exporting to Word95
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-03 13:52 UTC by M Runesson
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 20:23:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
An OpenOffice doc with swedich char. (4.99 KB, application/OpenOffice)
2003-05-03 13:57 UTC, M Runesson
no flags Details
this patch would do the trick for 1.1.2 (19.09 KB, patch)
2004-08-18 12:12 UTC, Caolan McNamara
no flags Details | Diff

Description M Runesson 2003-05-03 13:52:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
When writing a document in Swedish using the swedish char (������, described as
A with a ring, A with two dots, and O with two dots).

When exporting the document to Word 95 the swedish char is wrong, they are still
encoded as UTF-8, which Word does not understand. You will get the same error
when importing the file to OOo again.

Version-Release number of selected component (if applicable):
openoffice-1.0.2-4

How reproducible:
Always

Steps to Reproduce:
1. Write ������ in an OOo doc.
2. Export it as Word 95
3. Open the Word95 file in either Word or OpenOffice.

    

Actual Results:  You do not see the same characters.

Expected Results:  To see the same characters.

Additional info:

Comment 1 M Runesson 2003-05-03 13:57:09 UTC
Created attachment 91486 [details]
An OpenOffice doc with swedich char.

Open this doc in OpenOffice.
Save it as Word 95.
Close OpenOffice.
Start OpenOffice.
Open the Word95 file And you do not see the same file as you exported.

You can also try to open the Word file in Word95 and get the same error.

Comment 2 Dan Williams 2004-02-27 16:21:39 UTC
Please try current OOo 1.1.0, and reopen if problem still occurs

Comment 3 M Runesson 2004-02-27 18:08:37 UTC
Still the same problem using 1.1.0
Usig FC1 RPM: openoffice.org-1.1.0-6

Comment 4 Dan Williams 2004-02-27 20:30:58 UTC
I mean latest OOo in rawhide, meaning openoffice.org-1.1.0-28

Comment 5 M Runesson 2004-02-29 12:04:34 UTC
Still the same problem in openoffice.org-1.1.0-28

Comment 6 Dan Williams 2004-08-16 14:12:21 UTC
caolan, can you take a look?

Comment 7 Caolan McNamara 2004-08-17 07:57:05 UTC
as a temporary workaround

> export LANG=""
> oowriter

and then export to word95

clearly something is using the system encoding, and if you run 
> locale 
you've probably got a utf-8 encoding.

I'll investigate to see if this is a OOo error, or an unavoidable
artifact of the word95 format which is must use 8bit encodings unlike
the word97 one which is true unicode.

Comment 8 Caolan McNamara 2004-08-17 09:07:55 UTC
Firstly I've got the up and coming OpenOffice.org fixed
http://www.openoffice.org/issues/show_bug.cgi?id=33074

Secondly lets look at 1.1.X, I modified this stuff a lot for 2.0
because I was unhappy with the pre 2.0 code.



Comment 9 Caolan McNamara 2004-08-18 12:12:28 UTC
Created attachment 102837 [details]
this patch would do the trick for 1.1.2

Comment 10 Caolan McNamara 2004-08-20 06:53:05 UTC
Submitted patch for 1.1.X to upstream ooo-build

Comment 11 Caolan McNamara 2004-09-20 07:54:44 UTC
Will work in dans 1.1.2-5 testing rpm from
http://people.redhat.com/dcbw/fc3

Comment 12 Dan Williams 2004-09-25 20:23:10 UTC
1.1.2-5 has hit rawhide, so this should be fixed.  If its not, please
reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.