Bug 90149 - Slow application launch in Red Hat
Slow application launch in Red Hat
Status: CLOSED DUPLICATE of bug 73661
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 10:41 EDT by Mitsu Hadeishi
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitsu Hadeishi 2003-05-03 10:41:27 EDT
Description of problem: 
 
This probably is NOT a kernel problem but I have no idea where the problem is so it is 
going here for now. 
 
I have noticed (and I have read articles in which others have commented on this) that 
Red Hat 9 takes a very long time to launch applications.  For example, launching 
OpenOffice for the first time can take a minute or more on a relatively new Pentium 4 
laptop. I have also noticed similarly slow performance while copying large numbers of 
files.  Doing hdparm indicates that I am getting a decent 15-16 MB/sec, so DMA is 
working fine. 
 
The reason I post this as a problem is that under Mandrake 9.1 on the same machine, 
performance is a lot faster.  About 25 seconds to launch OpenOffice (writer). 
 
Mandrake is using a slightly newer kernel but I doubt this is the problem.  Any thoughts?  
Why is this?  In many ways I would prefer to use Red Hat 9 since it seems to be a bit 
more stable than Mandrake 9.1, but the slow performance is a killer. 
 
 
 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
 
 
Steps to Reproduce: 
1. 
2. 
3. 
     
Actual results: 
 
 
Expected results: 
 
 
Additional info:
Comment 1 Mitsu Hadeishi 2003-05-06 09:01:02 EDT
I was discussing this problem with a friend of mine familiar with kernel development and 
he thought that it might actually be kernel related.  Newer kernels have added 
optimizations allowing for better real-time response, which have to do with allocating 
more time to certain types of foreground I/O operations.  Basically, I think what might be 
at issue here is foreground application priority (including giving timeslices to launching 
applications). 
 
Comment 2 Mitsu Hadeishi 2003-05-07 02:25:10 EDT
AHA!  I discovered the answer to this problem!!

After nosing around the Net for a while I discovered it: the problem is
magicdev.  Remove the magicdev package, and suddenly Open Office goes from 100
seconds to launch to 15 seconds.  Clocked.

Yes, that's 100 seconds down to 15 seconds.  And I have read other people
reporting the same thing.  There is something seriously wrong with magicdev at
least on some systems (mine is an Inspiron 8200).  Magicdev should definitely be
reexamined.

This bug should be reassigned to someone who knows about magicdev.
Comment 3 Mitsu Hadeishi 2003-05-07 10:41:58 EDT

*** This bug has been marked as a duplicate of 73661 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:52:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.