Bug 901515 - AttributeError: 'NoneType' object has no attribute 'default'
AttributeError: 'NoneType' object has no attribute 'default'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Kolman
Release Test Team
:
Depends On:
Blocks: 960065 841211
  Show dependency treegraph
 
Reported: 2013-01-18 06:20 EST by Jan Stodola
Modified: 2015-09-27 22:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: anaconda-13.21.197-1
Doc Type: Bug Fix
Doc Text:
Cause: Availability of the "core" package group in selected repositories, required for successfully installation, was not checked before proceeding to the package installation phase. Consequence: When no selected repository had the "core" package group, installation ended with an exception when proceeding to package installation. Fix: Check if selected repositories have the "core" package group and if they don't, show a warning dialog instead of proceeding to the next step. Result: If the selected repositories don't contain the "core" group, a warning dialog is shown and the installation is blocked until a repository containing the "core" group is added.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 04:58:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2013-01-18 06:20:39 EST
Description of problem:
Following traceback is displayed when user tries to use only additional repository for the installation:

anaconda 13.21.194 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/task_gui.py", line 529, in <lambda>
    "default", False), grps)
  File "/usr/lib/anaconda/iw/task_gui.py", line 529, in getNext
    "default", False), grps)
  File "/usr/lib/anaconda/gui.py", line 1384, in nextClicked
    rc = self.currentWindow.getNext ()
AttributeError: 'NoneType' object has no attribute 'default'

Version-Release number of selected component (if applicable):
anaconda-13.21.194

How reproducible:
always

Steps to Reproduce:
1. start installation in graphical mode
2. proceed to the software selection screen
3. unselect "Red Hat Enterprise Linux" repository, which is selected by default
4. select any additional repository, for example "High Availability"
5. click "Next"

Actual results:
anaconda  traceback

Expected results:
There should be some warning message, user should be able to go back and select correct repositories.
Comment 3 RHEL Product and Program Management 2013-05-06 17:14:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 8 Martin Kolman 2013-07-17 06:27:14 EDT
Fixed both in GUI and TUI.

In GUI it now shows a dialog that notifies that none of the selected repositories have the core package group and won't allow to continue the installation until some repos containing the core package group are added.

And in TUI, if none of the repositories specified in kickstart (as there is no standalone repository dialog in TUI) contains the core group, it shows a warning dialog and exits.
Comment 10 Jan Stodola 2013-09-26 07:32:14 EDT
Retested with anaconda-13.21.206-1.el6 from compose RHEL6.5-20130924.2. Anaconda doesn't allow the user to continue until base repository is selected.

Thanks, moving to VERIFIED.
Comment 12 errata-xmlrpc 2013-11-21 04:58:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html

Note You need to log in before you can comment on or make changes to this bug.