Bug 90152 - Desktop rpm installer should give feedback on failure
Summary: Desktop rpm installer should give feedback on failure
Status: CLOSED DUPLICATE of bug 88343
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-03 15:48 UTC by Mitsu Hadeishi
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mitsu Hadeishi 2003-05-03 15:48:10 UTC
Description of problem: 
 
If you attempt to install an rpm from the desktop and it results in an error or failure, the 
installer should report the error in a dialog box.  Instead, it simply exits silently, forcing 
the user to search through log files and/or run the installer from the command line to 
determine what went wrong. 
 
Version-Release number of selected component (if applicable): 
 
Running the rpm installer in Red Hat 9. 
 
How reproducible: 
 
Whenever the installer exits abruptly 
 
Steps to Reproduce: 
1. Attempt to install an rpm from the desktop that would cause the rpm installer to fail 
2.  
3. 
     
Actual results: 
 
RPM installer begins by looking at dependencies, and then the progress bar disappears 
and the installer disappears with no feedback. 
 
Expected results: 
 
The RPM installer should display an error message, such as the error output, to give 
the user some indication of what went wrong, or that something went wrong. 
 
Additional info:

Comment 1 Jeremy Katz 2003-05-16 20:45:12 UTC
If you run 'redhat-install-packages foo' from the command line, what sort of
output do you get?

Comment 2 Mitsu Hadeishi 2003-05-16 21:05:58 UTC
Running it from the command line does give some useful feedback in every case. 
The problem is, for the newbie user (which I was), it is quite confusing when it
fails without giving any indication of why.  I should note that it does give
graphical feedback sometimes (i.e., when a dependency check has failed), but not
at other times (if the rpm database is corrupted, and in other cases).


Comment 3 Jeremy Katz 2003-05-16 21:50:09 UTC
I'm adding feedback for the cases that are detectable as I get them... without
knowing specifically where you're hitting problems, it's hard to do more.   I've
already got exception catching around everything I can think of.

Comment 4 Mitsu Hadeishi 2003-05-18 15:45:03 UTC
Okay, here's an example.  Attempt to install libdvdcss-1.2.6-fr2.i386.rpm, and
the following comes out on the command line:

redhat-install-packages libdvdcss-1.2.6-fr2.i386.rp              m
error: cannot open Packages database in /var/lib/rpm
warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID e42d547b
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/SinglePackageWindow.py", line 252, in
              ?
    main_window.run()
  File "/usr/share/redhat-config-packages/SinglePackageWindow.py", line 216, in
              run
    self.do_initial_setup ()
  File "/usr/share/redhat-config-packages/SinglePackageWindow.py", line 145, in
              do_initial_setup
    h = ts.hdrFromFdno(fd)
rpm.error: public key not available

Note that the problem is NOT that the Packages database is unavailable ---
running it on another package works fine.

You can download this rpm here:

http://rpmfind.net/linux/RPM/Shrike_Freshrpms.html

Of course, this might not be the right .rpm to install on my system, but the
point is that it is failing with no graphical feedback.

Now that I check, it appears that this problem always happens with packages with
"-fr" in the filename; does this mean they are from freshrpms?  In any case, the
-fr packages always seem to fail in the above way.

Comment 5 Barry K. Nathan 2003-05-18 21:10:37 UTC
Mitsu, that's bug 88343.

Comment 6 Jeremy Katz 2003-05-25 17:54:48 UTC

*** This bug has been marked as a duplicate of 88343 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:52:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.