Bug 90164 - left-handed intellimouse switches buttons incorrectly
left-handed intellimouse switches buttons incorrectly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: control-center (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 19:28 EDT by Hal Black
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-13 11:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hal Black 2003-05-03 19:28:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Switching to left-handed mouse makes the wheel button "left-click" instead of
the right button.

Version-Release number of selected component (if applicable):
control-center-2.2.0.1-9

How reproducible:
Always

Steps to Reproduce:
1. Switch to left-handed mouse

    

Actual Results:  middle button is left-click

Expected Results:  right button is left-click

Additional info:
Comment 1 Hay 2004-02-17 05:09:18 EST
Have a simular problem when swapping the left and right mouse button.

It works fine on the applications, but it doesn't work on the KDE
application menu and KDE panel.

After the change I even did a restart of the test system to double check.

Running fully up2date Fedora Core 2.

Extra: THis problem was also in one of the Fedora Core 1 test
releases, but was fixed in de official FC1

Best regard,
Hay
Comment 2 Hal Black 2004-02-17 07:06:29 EST
Here is a bit of information / workaround for the problem I was having:

When I was using the mouse as a USB mouse, the problem was present. 
If I used it as a PS/2 mouse with the port adapter hardware, the
buttons switched as expected.
Comment 3 Hal Black 2004-02-19 21:35:31 EST
Okay, the PS/2 workaround doesn't work in Fedora Core 2 test 1.
To add to Hay's comments, the gnome panel also doesn't work (in
addition to the KDE panel)
Comment 4 Hal Black 2004-02-29 13:04:48 EST
Some additional information: this is with the Microsoft Intellimouse
Optical USB.
Comment 5 Ray Strode [halfline] 2005-05-12 11:46:05 EDT
Hi,
I'm going through bugs assigned to me and attempting to clean some of the older,
fixed ones up.

This bug hasn't changed in over a year old now.  Are you still seeing the problem? 

(This a batch message is being sent to all my bugs that haven't changed in a year)
Comment 6 Hal Black 2005-05-12 20:16:12 EDT
Looks like this works now in Fedora Core 4 Test 2 for Gnome.  I can't figure out
how to bring up the configuration panel for KDE.
Comment 7 Ray Strode [halfline] 2005-05-13 11:01:33 EDT
Great, thanks.  I'll close the bug.

Note You need to log in before you can comment on or make changes to this bug.