Bug 901668 - Firefox crash on startup - assertion `GDK_IS_KEYMAP (keymap)' failed
Firefox crash on startup - assertion `GDK_IS_KEYMAP (keymap)' failed
Status: CLOSED DUPLICATE of bug 895197
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 13:53 EST by Ian Pilcher
Modified: 2013-01-18 14:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 14:29:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2013-01-18 13:53:42 EST
Description of problem:
When starting Firefox with the "default" profile, the main window appears and immediately disappears.  Starting in a terminal shows:

(firefox:7272): Gdk-CRITICAL **: gdk_keymap_have_bidi_layouts: assertion `GDK_IS_KEYMAP (keymap)' failed

(firefox:7272): GLib-GObject-WARNING **: cannot register existing type `GdkKeymap'

(firefox:7272): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(firefox:7272): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(firefox:7272): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

Version-Release number of selected component (if applicable):
firefox-18.0-1.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. firefox -P default
  
Actual results:
Assertion fails.  Crash.

Expected results:
No crash.

Additional info:
Other profiles work; there's something about my default profile that is causing the crash.  (Note that this just started happening; I did not update Firefox.)

Also, starting Firefox with "/usr/lib64/firefox/firefox -P default" works, so the launcher script seems to be involved somehow.
Comment 1 Martin Stransky 2013-01-18 14:16:47 EST
I guess you're hitting Bug 895197 so try to disable Java (icedtea) and try again.
Comment 2 Ian Pilcher 2013-01-18 14:29:53 EST
(In reply to comment #1)
> I guess you're hitting Bug 895197 so try to disable Java (icedtea) and try
> again.

I had already disabled the Java plugin (Tools -> Add-ons).  I can't uninstall the package, because I need javaws.

icedtea-web-1.3.1-3.fc18 seems to fix.

*** This bug has been marked as a duplicate of bug 895197 ***

Note You need to log in before you can comment on or make changes to this bug.