Bug 90175 - xmms segfaults if entry in playlist does not exist
Summary: xmms segfaults if entry in playlist does not exist
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xmms   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-04 19:07 UTC by Youssef Makki
Modified: 2014-03-17 02:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-05 18:26:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Youssef Makki 2003-05-04 19:07:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
If I load a .pls playlist and xmms reaches an entry of a file that has been
moved or so, it segfaults.
I first encountered this with a playlist of files on an smb share, but
duplicated it locally. I got the same results after disabling any extra plugins
I installed (except xmms-mp3), listed below.


Version-Release number of selected component (if applicable):
xmms-1.2.7-21.p

How reproducible:
Always

Steps to Reproduce:
1. Add a file to the playlist
2. Move/delete the file
3. Play that entry in the playlist


Actual Results:  Segmentation fault

Expected Results:  xmms should move to the next entry in the playlist

Additional info:

Versions of xmms and installed plugins:

xmms-mp3-1.2.7-21.p
xmms-itouch-0.1.2-fr2
xmms-devel-1.2.7-21.p
xosd-xmms-2.2.1-fr1
xmms-1.2.7-21.p

Comment 1 Bill Nottingham 2003-05-05 16:34:33 UTC
Works for me with the ogg vorbis plugin. Can you reproduce this at all without
*any* mp3 plugins?

Comment 2 Youssef Makki 2003-05-05 17:10:22 UTC
You're right, works the way it should without xmms-mp3-1.2.7-21.p


Comment 3 Bill Nottingham 2003-05-05 18:26:15 UTC
OK, closing. You'll probably want to take this up with upstream xmms, or
something similar.


Note You need to log in before you can comment on or make changes to this bug.