This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 901758 - non-free code for json decoder
non-free code for json decoder
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal 901759
  Show dependency treegraph
 
Reported: 2013-01-18 20:40 EST by Michael Scherer
Modified: 2013-01-19 14:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-19 14:37:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2013-01-18 20:40:48 EST
According to http://lintian.debian.org/tags/license-problem-json-evil.html and to a quick check by myself, mono has a file under a problematic license, stating :
"
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.

The Software shall be used for Good, not Evil.
"
According to http://wiki.debian.org/qa.debian.org/jsonevil , this make the license non-free, and so the code should be cleaned.
Comment 1 Christian Krause 2013-01-19 10:33:14 EST
Upstream changed the the License of that file (mcs/class/System.Web.Extensions/System.Web.Script.Serialization/JsonDeserializer.cs) 2 months ago with the following comment:

"Removed original license since no substantial portions of the original software are used in our implementation":

https://github.com/mono/mono/commit/7b1d9f179c5ca5fea93443793356bf9695bf3dbc

Besides the license change, the only difference between git HEAD of that file and the one included in mono 2.10.8 (which is the latest version in Fedora) is:

-----------------------------
 using System;
 using System.Collections;
@@ -302,7 +276,6 @@
 		JsonType jsonType;
 		
 		bool escaped;
-		bool negated;
 		int state;
 		Stack <string> currentKey;
 		StringBuilder buffer;
-----------------------------

I would assume, that upstream's statement, that "no substantial portion of the original software are used", also holds for the current version of that file in mono 2.10.8. If strictly necessary, it would be possible rebuild mono for all Fedora releases and use the git HEAD version of that file. I'm not sure whether that is necessary.

The final decision should be done by Fedora-Legal.
Comment 2 Tom "spot" Callaway 2013-01-19 14:37:53 EST
I agree. It is safe to assume that the broken JSON license is not in play on the current mono file in Fedora. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.