Bug 901784 - submitting job with a custom repo error: (OperationalError) (1048, "Column \'recipe_id\' cannot be null") \'INSERT INTO recipe_repo (recipe_id, name, url)
submitting job with a custom repo error: (OperationalError) (1048, "Column \'...
Status: CLOSED DUPLICATE of bug 896622
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.11
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: beaker-dev-list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-19 01:59 EST by Guangze Bai
Modified: 2015-02-08 16:38 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-20 15:48:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Guangze Bai 2013-01-19 01:59:41 EST
Description of problem:

$ bkr job-submit CrasherBug.xml
Exception: <Fault 1: '<class \'sqlalchemy.exc.OperationalError\'>:(OperationalError) (1048, "Column \'recipe_id\' cannot be null") \'INSERT INTO recipe_repo (recipe_id, name, url) VALUES (%s, %s, %s)\' (None, \'kexec-tools\', \'http://lacrosse.corp.redhat.com/gbai/repos/kexec-tools-2.0.0-258.el6/\')'>


Version-Release number of selected component (if applicable):
0.11.0

How reproducible:
always with a multiple 'recipeSet' job which uses a custom <repo> 

Steps to Reproduce:
I'll attach a job xml I'm using as an example.

Additional info:
It's always working for me but not now. Maybe due to recent beaker upgrade.
Comment 2 Dan Callaghan 2013-01-20 15:48:14 EST

*** This bug has been marked as a duplicate of bug 896622 ***

Note You need to log in before you can comment on or make changes to this bug.