Bug 901812 - [abrt] systemd-197-1.fc18.1: crash: Process /usr/lib/systemd/systemd was killed by signal 7 (SIGBUS)
[abrt] systemd-197-1.fc18.1: crash: Process /usr/lib/systemd/systemd was kill...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eric Paris
Fedora Extras Quality Assurance
abrt_hash:32e8ced2dbf3dc687659c540125...
:
: 902354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-19 08:34 EST by Jeffrey C. Ollie
Modified: 2013-03-16 21:00 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-16 20:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.62 KB, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: cgroup (122 bytes, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: core_backtrace (1.06 KB, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: dso_list (2.21 KB, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: environ (143 bytes, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: maps (9.73 KB, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: open_fds (648 bytes, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: proc_pid_status (881 bytes, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details
File: var_log_messages (13.39 KB, text/plain)
2013-01-19 08:34 EST, Jeffrey C. Ollie
no flags Details

  None (edit)
Description Jeffrey C. Ollie 2013-01-19 08:34:31 EST
Version-Release number of selected component:
systemd-197-1.fc18.1

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd --switched-root --system --deserialize 32
crash_function: crash
executable:     /usr/lib/systemd/systemd
kernel:         3.7.2-201.fc18.x86_64
remote_result:  NOTFOUND
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #1 crash at src/core/main.c:137
 #3 pcre_exec at pcre_exec.c:6409
 #4 lookup at label_file.c:618
 #5 selabel_lookup_common at label.c:197
 #6 selabel_lookup_raw at label.c:233
 #7 label_mkdir at src/shared/label.c:267
 #8 makedir_p at src/shared/mkdir.c:134
 #9 create_generator_dir at src/core/manager.c:2260
 #11 manager_run_generators at src/core/manager.c:2316
 #12 manager_reload at src/core/manager.c:2075
Comment 1 Jeffrey C. Ollie 2013-01-19 08:34:34 EST
Created attachment 683021 [details]
File: backtrace
Comment 2 Jeffrey C. Ollie 2013-01-19 08:34:36 EST
Created attachment 683022 [details]
File: cgroup
Comment 3 Jeffrey C. Ollie 2013-01-19 08:34:37 EST
Created attachment 683023 [details]
File: core_backtrace
Comment 4 Jeffrey C. Ollie 2013-01-19 08:34:39 EST
Created attachment 683024 [details]
File: dso_list
Comment 5 Jeffrey C. Ollie 2013-01-19 08:34:41 EST
Created attachment 683025 [details]
File: environ
Comment 6 Jeffrey C. Ollie 2013-01-19 08:34:42 EST
Created attachment 683026 [details]
File: limits
Comment 7 Jeffrey C. Ollie 2013-01-19 08:34:44 EST
Created attachment 683027 [details]
File: maps
Comment 8 Jeffrey C. Ollie 2013-01-19 08:34:46 EST
Created attachment 683028 [details]
File: open_fds
Comment 9 Jeffrey C. Ollie 2013-01-19 08:34:48 EST
Created attachment 683029 [details]
File: proc_pid_status
Comment 10 Jeffrey C. Ollie 2013-01-19 08:34:49 EST
Created attachment 683030 [details]
File: var_log_messages
Comment 11 Michal Schmidt 2013-01-21 09:03:09 EST
The crash happened when trying to lookup the SELinux label for "/run/systemd/generator", inside the pcre library (which is used by libselinux).

Is the crash reproducible? What is the version of selinux-policy? Have you added any custom SELinux file context mappings?
Comment 12 Michal Schmidt 2013-01-21 11:37:50 EST
*** Bug 902354 has been marked as a duplicate of this bug. ***
Comment 13 Michal Schmidt 2013-01-21 12:21:44 EST
I found an older abrt report where with a similar top of the stack:
http://retrace.fedoraproject.org/faf/problems/73502/

I don't think this is systemd's bug. I'm reassigning this to one level below systemd, i.e. libselinux.
Comment 14 Eric Paris 2013-01-21 16:44:49 EST
Is there a reliable reproducer here?
Comment 15 ZiN 2013-01-23 04:59:17 EST
It (bz#902354) actually happens not the first time but often (if not every time) after selinux update, on different machines, though, but I haven't filed a bug report on it before this occurrence.
Comment 16 ZiN 2013-01-23 05:18:49 EST
When it happens I'm not even able to reboot, neither remotely nor locally, so that I have to press reset key. I'm not able to stop/start/restart services. The reason is one: cannot send messages to systemd. This is a very big regression and instability factor.
Comment 17 Michal Schmidt 2013-01-23 09:05:59 EST
(In reply to comment #15)
> It (bz#902354) actually happens not the first time but often (if not every
> time) after selinux update

What exactly do you mean by selinux update? An update of a SELinux-related package? Which one?

In bug 902354 you wrote:
> Description of problem:
> Change SELinux boolean
> setsebool -P httpd_can_network_connect_cobbler=on

Is this command what you mean by selinux update?

Did the crash happen immediately afterwards? Or was some other action needed?
Please be more exact in describing the steps that lead to the crash.


(In reply to comment #16)
> I have to press reset key.

A tip for you: "sync && reboot -f" is a little bit safer than hard reset button.
Comment 18 Daniel Walsh 2013-01-28 11:37:28 EST
A policy update will cause systemd to reread the SELinux policy files.  I guess this could be causing the problem.

load_policy 

Should be able to trigger this.
Comment 19 ZiN 2013-03-02 19:51:43 EST
(In reply to comment #17)
> (In reply to comment #15)
> > It (bz#902354) actually happens not the first time but often (if not every
> > time) after selinux update
> 
> What exactly do you mean by selinux update? An update of a SELinux-related
> package? Which one?
> 
> In bug 902354 you wrote:
> > Description of problem:
> > Change SELinux boolean
> > setsebool -P httpd_can_network_connect_cobbler=on
> 
> Is this command what you mean by selinux update?
> 
> Did the crash happen immediately afterwards? Or was some other action needed?
> Please be more exact in describing the steps that lead to the crash.
> 
> 
> (In reply to comment #16)
> > I have to press reset key.
> 
> A tip for you: "sync && reboot -f" is a little bit safer than hard reset
> button.

Sorry, I haven't look carefully your reply, while I have seen that there where some replies.

Thank you for a tip about more safe reboot.

As I remeber, the systemd bug have been occuring after sepol related packages update and after setsebool executing also. It seemes that it happend immediately afterwards, anyway after those actions immediately (setsebool) or after some time something happened that I could not reboot with systemd nor could I control services with it.
Comment 20 David Highley 2013-03-05 22:03:58 EST
Dan, I tried your suggestion of load_policy, comment 18, on the system where we have experienced this issue twice. It did not trigger the issue though. We think the last event was triggered by doing a setsebool -P rsync_full_access off after doing an update to selinux-policy-3.11.1-82.fc18.noarch.
Comment 21 Daniel Walsh 2013-03-06 15:23:29 EST
I have added a fix to libselinux-2.1.12-7.2.fc18 which will cause the creation of the .bin file to be atomic, which could be a cause of this error.  Basically if an app tried to read the file while i was being written.
Comment 22 Fedora Update System 2013-03-06 15:25:43 EST
libselinux-2.1.12-7.2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libselinux-2.1.12-7.2.fc18
Comment 23 Michal Schmidt 2013-03-07 08:53:45 EST
I see. As a test I ran this in one terminal:

 while matchpathcon /run/systemd/generator > /dev/null; do :; done

and repeatedly tried this in another:

 sefcontext_compile /etc/selinux/targeted/contexts/files/file_contexts

With the original libselinux it was easy to make matchpathcon crash. With the new one it didn't crash.

I also verified that "setsebool -P ..." somehow triggers the recompilation of file_contexts.bin.

It is reasonable to expect this bug is indeed fixed by the new libselinux.
Comment 24 Fedora Update System 2013-03-07 19:00:50 EST
Package libselinux-2.1.12-7.2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libselinux-2.1.12-7.2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3531/libselinux-2.1.12-7.2.fc18
then log in and leave karma (feedback).
Comment 25 Fedora Update System 2013-03-16 21:00:01 EDT
libselinux-2.1.12-7.2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.