Bug 90185 - Console usage of timeconfig is broken
Summary: Console usage of timeconfig is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 85220 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-05 05:20 UTC by Joe Cooper
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-22 15:22:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of timeconfig (14.60 KB, image/gif)
2003-06-10 18:27 UTC, Bill McCarty
no flags Details

Description Joe Cooper 2003-05-05 05:20:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

Description of problem:
timeconfig/dateconfig will not run on a text-only system.

When attempting to run timeconfig the following python traceback occurs:

[root@localhost root]# timeconfig
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/timeconfig.py", line 29, in ?
    from timezone_map_gui import ZoneTab
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 16, in ?
    import gobject
ImportError: No module named gobject

When attempting to run dateconfig the following error is issued:

[root@localhost root]# dateconfig
redhat-config-date requires a currently running X server.

I see mention of a tui being added to timeconfig in the RPM changelong back in
1.57, but I suppose there has been a regression, or maybe it never really worked.

Version-Release number of selected component (if applicable):
1.5.9-8

How reproducible:
Always

Steps to Reproduce:
1. Login to a text-only Red Hat 9 system
2. Run timeconfig

Actual Results:  traceback:

[root@localhost root]# timeconfig
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/timeconfig.py", line 29, in ?
    from timezone_map_gui import ZoneTab
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 16, in ?
    import gobject
ImportError: No module named gobject


Expected Results:  The timeconfig tool should allow the user to set the
timezone.  I suppose the new tools have time and date settings, too, but there
is a relatively easy way to set those from the command line so I can live
without them.  Timezone is the difficult one.

Additional info:

Comment 1 Brent Fox 2003-05-22 15:22:49 UTC
Ah, timeconfig.py is importing timezone_map_gui to get a listing of the
timezones.  The only problem is that timezone_map_gui is importing gobject,
which is part of pygtk, which probably isn't installed on your system if you
don't have X and Gnome installed.

What I've done now is to pull the ZoneTab and ZoneTabEntry classes (which are
the only classes that timeconfig.py needs) out into a separate file, which will
avoid the importing of gobject.  Thus, timeconfig should now be able to run in
text mode without pygtk installed and redhat-config-date (the GUI part) should
also work fine if pygtk is installed. 

This should be fixed in redhat-config-date-1.5.10-1 in Rawhide soon.

Comment 2 Joe Cooper 2003-05-22 18:52:14 UTC
Thanks, Brent!  Looking forward to the update.

Comment 3 Brent Fox 2003-05-23 16:51:32 UTC
*** Bug 85220 has been marked as a duplicate of this bug. ***

Comment 4 Bill McCarty 2003-06-10 18:27:04 UTC
Created attachment 92320 [details]
Screen shot of timeconfig

Comment 5 Bill McCarty 2003-06-10 18:29:06 UTC
As shown in the screen shot above, the version of timeconfig currently in
rawhide, redhat-config-date-1.5.13-1.noarch.rpm, does indeed fix my problem.
And, configuring putty for UTF-8 and resetting the terminal yields a reassonably
good rendering of the screen.

Thanks!

Comment 6 Brent Fox 2003-06-11 20:02:37 UTC
Good.  Thanks for working with us on this report. 


Note You need to log in before you can comment on or make changes to this bug.