Bug 901879 - [abrt] ibus-libpinyin-1.4.93-4.fc18: pinyin::ChewingLengthIndexLevel::load: Process /usr/libexec/ibus-engine-libpinyin was killed by signal 6 (SIGABRT)
[abrt] ibus-libpinyin-1.4.93-4.fc18: pinyin::ChewingLengthIndexLevel::load: P...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-libpinyin (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
abrt_hash:b9896382f566ee7f7d7a7161e1a...
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-19 13:54 EST by Marcel Wysocki
Modified: 2013-03-05 18:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-02 15:09:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (18.30 KB, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: cgroup (129 bytes, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: core_backtrace (4.13 KB, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: dso_list (3.33 KB, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: environ (1.10 KB, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: maps (15.29 KB, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: open_fds (366 bytes, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: proc_pid_status (926 bytes, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
File: smolt_data (3.05 KB, text/plain)
2013-01-19 13:54 EST, Marcel Wysocki
no flags Details
backstrace (17.59 KB, application/octet-stream)
2013-02-27 04:32 EST, Christopher Meng
no flags Details
Maps (9.55 KB, application/octet-stream)
2013-02-27 04:34 EST, Christopher Meng
no flags Details
Environment (1.01 KB, application/octet-stream)
2013-02-27 04:34 EST, Christopher Meng
no flags Details

  None (edit)
Description Marcel Wysocki 2013-01-19 13:54:33 EST
Version-Release number of selected component:
ibus-libpinyin-1.4.93-4.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-engine-libpinyin --ibus
crash_function: pinyin::ChewingLengthIndexLevel::load
executable:     /usr/libexec/ibus-engine-libpinyin
kernel:         3.6.9-4.fc18.x86_64
uid:            1000
var_log_messages: Dec 23 11:03:31 schweinchen abrt[4470]: Saved core dump of pid 4466 (/usr/libexec/ibus-engine-libpinyin) to /var/spool/abrt/ccpp-2012-12-23-11:03:31-4466 (11730944 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 pinyin::ChewingLengthIndexLevel::load at chewing_large_table.cpp:811
 #5 pinyin::ChewingBitmapIndexLevel::load at chewing_large_table.cpp:701
 #6 load at ../src/storage/chewing_large_table.h:114
 #8 pinyin_init at pinyin.cpp:150
 #9 PY::LibPinyinBackEnd::initPinyinContext at PYLibPinyin.cc:67
 #10 PY::LibPinyinBackEnd::allocPinyinInstance at PYLibPinyin.cc:89
 #11 PY::LibPinyinFullPinyinEditor::LibPinyinFullPinyinEditor at PYPFullPinyinEditor.cc:32
 #12 PY::LibPinyinPinyinEngine::LibPinyinPinyinEngine at PYPPinyinEngine.cc:60
 #13 PY::ibus_pinyin_engine_constructor at PYEngine.cc:162
 #15 g_object_new_valist at gobject.c:1835
Comment 1 Marcel Wysocki 2013-01-19 13:54:37 EST
Created attachment 683178 [details]
File: backtrace
Comment 2 Marcel Wysocki 2013-01-19 13:54:39 EST
Created attachment 683179 [details]
File: cgroup
Comment 3 Marcel Wysocki 2013-01-19 13:54:42 EST
Created attachment 683180 [details]
File: core_backtrace
Comment 4 Marcel Wysocki 2013-01-19 13:54:44 EST
Created attachment 683181 [details]
File: dso_list
Comment 5 Marcel Wysocki 2013-01-19 13:54:47 EST
Created attachment 683182 [details]
File: environ
Comment 6 Marcel Wysocki 2013-01-19 13:54:49 EST
Created attachment 683183 [details]
File: limits
Comment 7 Marcel Wysocki 2013-01-19 13:54:51 EST
Created attachment 683184 [details]
File: maps
Comment 8 Marcel Wysocki 2013-01-19 13:54:53 EST
Created attachment 683185 [details]
File: open_fds
Comment 9 Marcel Wysocki 2013-01-19 13:54:55 EST
Created attachment 683186 [details]
File: proc_pid_status
Comment 10 Marcel Wysocki 2013-01-19 13:54:58 EST
Created attachment 683187 [details]
File: smolt_data
Comment 11 Peng Wu 2013-01-20 22:10:38 EST
When will this crash happen?

Does it disappear after removing ~/.cache/ibus/libpinyin in the terminal?

If so, could you send me the above corrupted personal data by email for further analyzing?
Comment 12 Roger Chuen 2013-02-09 01:41:03 EST
I tried to rename a folder. And I switched ibus to input chinese words but with english characters instead when typing. And suddely the bug report dialog poped out. 

backtrace_rating: 4
Package: ibus-libpinyin-1.4.93-4.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 Peng Wu 2013-02-15 23:44:44 EST
(In reply to comment #12)

Sorry for replying lately.

Could you open a bug report by the bug report dialog?
Then I can analyze the backtrace to fix it. Thanks
Comment 14 Christopher Meng 2013-02-26 19:01:06 EST
I cannot startup ibus-libpinyin by pressing shift or ctrl-space. then it crashed.

This happened just after my kernel upgrade to 3.7.9.Before I use 3.7.4.


backtrace_rating: 4
Package: ibus-libpinyin-1.4.93-4.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 15 Peng Wu 2013-02-26 21:34:09 EST
Please remove ~/.cache/ibus/libpinyin and ~/.cache/ibus/libbopomofo when ibus-libpinyin is not running.

It seems the user data has been corrupted.
Please send me your user data for further analyzing.
The user data is in ~/.cache/ibus/libpinyin and ~/.cache/ibus/libbopomofo.
Comment 16 Christopher Meng 2013-02-27 04:32:07 EST
Created attachment 703333 [details]
backstrace
Comment 17 Christopher Meng 2013-02-27 04:34:26 EST
Created attachment 703335 [details]
Maps
Comment 18 Christopher Meng 2013-02-27 04:34:48 EST
Created attachment 703336 [details]
Environment
Comment 19 Christopher Meng 2013-02-27 04:35:03 EST
Uploaded.
Comment 20 Christopher Meng 2013-02-27 04:43:14 EST
3.7.7 tested ---- No problem again.
Comment 21 Christopher Meng 2013-02-27 04:46:45 EST
After deleting the files you mentioned before, 3.7.9 now can use ibus-libpinyin again.

So, is this the root cause?
Comment 22 Peng Wu 2013-02-27 08:03:36 EST
Thanks.

Yes, it is caused by the corrupted user data.

I will try to write some codes to detect the corrupted user data.
Comment 23 Fedora Update System 2013-02-28 00:58:22 EST
libpinyin-0.8.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libpinyin-0.8.1-1.fc17
Comment 24 Fedora Update System 2013-02-28 00:58:36 EST
libpinyin-0.8.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libpinyin-0.8.1-1.fc18
Comment 25 Fedora Update System 2013-03-02 15:00:25 EST
Package libpinyin-0.8.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libpinyin-0.8.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3234/libpinyin-0.8.1-1.fc17
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2013-03-02 15:09:53 EST
libpinyin-0.8.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2013-03-05 18:19:25 EST
libpinyin-0.8.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.