Bug 901902 - [abrt] ruby-1.9.3.362-24.fc18: rb_bug: Process /usr/bin/ruby was killed by signal 6 (SIGABRT)
[abrt] ruby-1.9.3.362-24.fc18: rb_bug: Process /usr/bin/ruby was killed by si...
Status: CLOSED DUPLICATE of bug 895173
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
abrt_hash:99230aa317771942fab3500f584...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-19 16:31 EST by Krzysztof Jurewicz
Modified: 2013-01-19 22:44 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-19 22:44:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (75.24 KB, text/plain)
2013-01-19 16:31 EST, Krzysztof Jurewicz
no flags Details
File: build_ids (3.68 KB, text/plain)
2013-01-19 16:31 EST, Krzysztof Jurewicz
no flags Details
File: cgroup (130 bytes, text/plain)
2013-01-19 16:31 EST, Krzysztof Jurewicz
no flags Details
File: core_backtrace (5.68 KB, text/plain)
2013-01-19 16:31 EST, Krzysztof Jurewicz
no flags Details
File: dso_list (7.35 KB, text/plain)
2013-01-19 16:32 EST, Krzysztof Jurewicz
no flags Details
File: environ (1.76 KB, text/plain)
2013-01-19 16:32 EST, Krzysztof Jurewicz
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-19 16:32 EST, Krzysztof Jurewicz
no flags Details
File: maps (39.87 KB, text/plain)
2013-01-19 16:32 EST, Krzysztof Jurewicz
no flags Details
File: open_fds (506 bytes, text/plain)
2013-01-19 16:32 EST, Krzysztof Jurewicz
no flags Details
File: proc_pid_status (925 bytes, text/plain)
2013-01-19 16:32 EST, Krzysztof Jurewicz
no flags Details
File: var_log_messages (1.20 KB, text/plain)
2013-01-19 16:32 EST, Krzysztof Jurewicz
no flags Details

  None (edit)
Description Krzysztof Jurewicz 2013-01-19 16:31:44 EST
Description of problem:
After updating some gems, running "rails server" and entering a specific URL on Rails app causes that bug repeatedly.

Version-Release number of selected component:
ruby-1.9.3.362-24.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/ruby script/rails server
crash_function: rb_bug
executable:     /usr/bin/ruby
kernel:         3.7.2-201.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 rb_bug at error.c:284
 #3 sigsegv at signal.c:609
 #5 rb_vm_make_env_object at vm.c:485
 #6 rb_vm_make_proc at vm.c:562
 #7 vm_make_proc_from_block at vm.c:546
 #8 rb_vm_make_env_object at vm.c:488
 #9 rb_vm_make_proc at vm.c:562
 #10 vm_make_proc_from_block at vm.c:546
 #11 rb_vm_make_env_object at vm.c:488
 #12 rb_vm_make_proc at vm.c:562

Potential duplicate: bug 704606
Comment 1 Krzysztof Jurewicz 2013-01-19 16:31:47 EST
Created attachment 683261 [details]
File: backtrace
Comment 2 Krzysztof Jurewicz 2013-01-19 16:31:50 EST
Created attachment 683262 [details]
File: build_ids
Comment 3 Krzysztof Jurewicz 2013-01-19 16:31:55 EST
Created attachment 683263 [details]
File: cgroup
Comment 4 Krzysztof Jurewicz 2013-01-19 16:31:58 EST
Created attachment 683264 [details]
File: core_backtrace
Comment 5 Krzysztof Jurewicz 2013-01-19 16:32:00 EST
Created attachment 683265 [details]
File: dso_list
Comment 6 Krzysztof Jurewicz 2013-01-19 16:32:02 EST
Created attachment 683266 [details]
File: environ
Comment 7 Krzysztof Jurewicz 2013-01-19 16:32:04 EST
Created attachment 683267 [details]
File: limits
Comment 8 Krzysztof Jurewicz 2013-01-19 16:32:06 EST
Created attachment 683268 [details]
File: maps
Comment 9 Krzysztof Jurewicz 2013-01-19 16:32:08 EST
Created attachment 683269 [details]
File: open_fds
Comment 10 Krzysztof Jurewicz 2013-01-19 16:32:13 EST
Created attachment 683270 [details]
File: proc_pid_status
Comment 11 Krzysztof Jurewicz 2013-01-19 16:32:15 EST
Created attachment 683271 [details]
File: var_log_messages
Comment 12 Mamoru TASAKA 2013-01-19 22:44:36 EST
Please try coming 1.9.3.374-27

*** This bug has been marked as a duplicate of bug 895173 ***

Note You need to log in before you can comment on or make changes to this bug.