This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 901984 - [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -35! [*** DATA LOSS ***]
[drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -35! [*** DATA LOSS ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-20 06:01 EST by Ali Akcaagac
Modified: 2013-02-28 10:03 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 10:03:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages.log file (142.25 KB, text/plain)
2013-01-20 06:01 EST, Ali Akcaagac
no flags Details

  None (edit)
Description Ali Akcaagac 2013-01-20 06:01:36 EST
Created attachment 683530 [details]
messages.log file

The Greetings:
--------------
Hi!

The Technical:
--------------
-bash-4.2$ uname -a
Linux localhost.localdomain 3.7.2-204.fc18.i686 #1 SMP Wed Jan 16 16:42:52 UTC 2013 i686 i686 i386 GNU/Linux
-bash-4.2$ 

-bash-4.2$ lspci | grep -i "Radeon"
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6320]
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
-bash-4.2$ 

The Problem:
------------
Using Fedora 18 here with above specs. When switching from X -> Console and then trying switching back to X I often get exactly the problems described in the summary.

Whenever this happens there is NO recovery (like going to another console, pressing power to have it shutdown, or sleep mode) the ONLY way to get rid of this is to hard power off the system. And this usually ends in huge DATA LOSS and FS corruption.

What visually happens is, that the notebook LCD is showing a strobo like effect, 

for (;;) {               // the endless loop
  printf(white);         // doing something in white for less than a sec
  printf(black);         // doing something in black for less than a sec
}

// poweroff
Comment 1 Ali Akcaagac 2013-01-20 06:40:18 EST
By the way, this allso happened with older version of the kernels (pre f18 release).
Comment 2 Pawel Dys 2013-01-22 11:30:24 EST
The same problem on Fedora 18 with kernel 3.7.2-204.fc18.i686:
lspci | grep -i "Radeon"
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6250]
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]

In /var/log/messages appears:
Jan 21 19:01:25 acer722 kernel: [  492.234153] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -35!
Jan 21 19:01:25 acer722 kernel: [  492.235313] radeon 0000:00:01.0: GPU reset succeeded, trying to resume
Jan 21 19:01:26 acer722 kernel: [  492.256307] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
Jan 21 19:01:26 acer722 kernel: [  492.257015] radeon 0000:00:01.0: WB enabled
Jan 21 19:01:26 acer722 kernel: [  492.257029] radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000010000c00 and cpu addr 0xff4b8c00
Jan 21 19:01:26 acer722 kernel: [  492.273736] [drm] ring test on 0 succeeded in 1 usecs
Jan 21 19:01:26 acer722 kernel: [  492.273784] [drm] ib test on ring 0 succeeded in 0 usecs

The problem arrives during waking up laptop from sleeping state (after opening lid). Screen is blinking and computer doesn't respond. I can only turn off computer (and lose all not saved data).
Comment 3 redhat 2013-02-05 07:20:35 EST
duplicate of 849347 ?
Comment 4 Pawel Dys 2013-02-09 03:34:04 EST
I've tried advices from https://bugzilla.redhat.com/show_bug.cgi?id=849347. Either iommu=off, amd_iommu=fullflush, amd_iommu=force_isolation nor upgrade mesa to mesa-9.0.1-4.fc18 don't help. Results similar to https://bugzilla.redhat.com/show_bug.cgi?id=849347#c50 (Vann Walke 2013-02-08 15:36:20 EST).
Comment 5 Jerome Glisse 2013-02-26 09:44:08 EST
Please update to xorg-x11-drv-ati-7.0.0-0.9.20121015gitbd9e2c064.fc18 it should fix your issue.
Comment 6 Jerome Glisse 2013-02-28 10:03:08 EST
Closing reopen if you still have the issue with xorg-x11-drv-ati-7.0.0-0.9.20121015gitbd9e2c064.fc18 or newer

Note You need to log in before you can comment on or make changes to this bug.