Bug 902014 - Grub2 option should be the default in KDM settings
Summary: Grub2 option should be the default in KDM settings
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
(Show other bugs)
Version: 18
Hardware: Unspecified Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-20 13:10 UTC by nicofo
Modified: 2013-01-21 20:09 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 00:10:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nicofo 2013-01-20 13:10:23 UTC
Description of problem:
In the settings of KDM (KDE -> Systemsettings > LoginScreen > Shutdown > "Boot Manager"), the drop-down list should select by default "GRUB2" (instead of "NONE") since Fedora is shipped with GRUB2.

Version-Release number of selected component (if applicable):
Fedora 18, fresh installation (KDE 4.9.5)

Actual results:
Boot Manager = None (default value)

Expected results:
Boot Manager = Grub2

Additional info:
This option is important for the integration of Grub2 into KDM, which doesn't work by default (after a fresh Fedora installation).
[i.e. KDM is able to be aware of the different kernels to which it can reboot from]

[Remark: there is no "KDM" component in the list of products ?]

Comment 1 Kevin Kofler 2013-01-21 00:10:52 UTC
No can do, sorry, selinux-policy maintainers won't allow it.

(And KDM is in kde-workspace, but this is about Fedora default settings, so kde-settings is the right component.)

Comment 2 nicofo 2013-01-21 19:11:15 UTC
OK, but what is the reason ? Can you provide an explanation ?

Does this mean that Grub2 integration in KDM is not possible (by default) in Fedora ? Yet it was presented as a Fedora 16 feature ! (see https://fedoraproject.org/wiki/Releases/16/FeatureList    ->     https://fedoraproject.org/wiki/Features/KDE47 )

Comment 3 Kevin Kofler 2013-01-21 20:09:46 UTC
> OK, but what is the reason ? Can you provide an explanation ?

They think that allowing the login manager to change bootloader configuration is inherently dangerous.

> Does this mean that Grub2 integration in KDM is not possible (by default) in
> Fedora ?

Yes, as long as SELinux is enabled by default (and I see no plans to change this, even though I'd support that) and as the SELinux maintainers keep their position, we cannot enable GRUB integration by default.

> Yet it was presented as a Fedora 16 feature !

The feature is that the option exists and can be enabled if you disable (or customize) SELinux at the same time. What's new in Fedora 16 is that it uses GRUB 2 instead of GRUB 1, which is why GRUB 2 support is mentioned in the KDE47 feature page at all.


Note You need to log in before you can comment on or make changes to this bug.