Bug 90211 - Can't resolv names after inactvity
Can't resolv names after inactvity
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-05 11:10 EDT by Pablo Endres
Modified: 2007-04-18 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pablo Endres 2003-05-05 11:10:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
After some time on inactivity of the browser.  It doesn't resolv names of the
solicited URL's.  For example you browse for a while, leave the browser open and
go to lunch (about an hour); when you come back to keep on browsing it can't
resolv any name.

It's peculiar because it doesn't give a timeout.. It simply keeps looking forever.

The machine and DNS are ok, because you can open le same pages you are looking
for through lynx o konquerer

Version-Release number of selected component (if applicable):
1.2.1-26

How reproducible:
Always

Steps to Reproduce:
1.Open Mozilla
2.Go to lunch o leave it alone for a while min. 30 minutes
3.try o open a new page
    

Actual Results:  It doesn't do anything

Expected Results:  Open the requested URL

Additional info:
Comment 1 Christopher Blizzard 2003-05-05 13:43:24 EDT
Is this easy to reproduce?  I've walked away for hours at a time without problems.  

If this happens again, can you toggle your online/offline switch int he lower
right hand corner and see if it fixes the problem?
Comment 2 David Kaplan 2003-08-12 15:31:54 EDT
I have this same problem all the time.  It sometimes happens though after little
time left undisturbed and seems to be happening more frequently (although
perhaps I am just being mental).  It also seems to be associated with bug #89431
- I fix it by closing all windows, but mozilla won't restart without killing a
stray process.

I will try toggling the online button next time it happens.
Comment 3 Kirby C. Bohling 2003-08-27 15:38:20 EDT
For whatever it's worth, I've had this bug happen to me on several occasions on
multiple machines.  It just happened on my machine.  My problem normally only
happens after several days of running Mozilla.  I close all the windows, and try
starting up a new mozilla

I then see this process, and it appears to just hang for a while:
/usr/lib/mozilla-1.2.1/mozilla-xremote-client ping()

This process runs, and hangs.  I believe it returns with an exit code of 3.  The
only way to resolve the problem is to kill the main mozilla session:

kbohling  2517  0.6 12.5 107036 32040 ?      S    Aug26  10:25
/usr/lib/mozilla-1.2.1/mozilla-bin -UILocale en-US

It's a stock RH9 install, with all of the patches applied to get me current.

I will try going offline, and coming back online.  I'll see if I can attach with
strace to the running process to see what it's haning on.

I don't believe I've got a Java JVM, or any other additional plugins besides the
default (Plugger 4.0).

I never had this problem with a stock 1.4 Mozilla install on RedHat 7.2.  I'll
try doing a stock install of Mozilla 1.4 in my home directory on this machine
and see if it hangs like this or not.

If there is anything additional I can do, like send the operation sig11, or sig2
to generate a core and use GDB to see if I can get a backtrace I'll be happy to
try that.

Comment 4 David Kaplan 2003-08-27 19:57:24 EDT
I tried toggling the offline-online switch and it didnt help.
Comment 5 Kirby C. Bohling 2003-09-02 16:28:45 EDT
#0  0xffffe002 in ?? ()
#1  0x403bb3fb in g_main_is_running () from /usr/lib/libglib-1.2.so.0
#2  0x403bacc5 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#3  0x403bb124 in g_main_run () from /usr/lib/libglib-1.2.so.0
#4  0x402c627f in gtk_main () from /usr/lib/libgtk-1.2.so.0
#5  0x41e752ba in NSGetModule () from
/usr/lib/mozilla-1.2.1/components/libwidget_gtk.so
#6  0x40cf34be in NSGetModule () from
/usr/lib/mozilla-1.2.1/components/libnsappshell.so
#7  0x08053470 in getCountry ()
#8  0x08053d81 in main ()
#9  0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6


Here is my backtrace.  I can't seem to past the frame it's currently in.  I can
get a complete list of libraries it's loaded (it's a really long list).

The odd part is that as soon as I attach to it in GDB and continue it then
resolves the name and continues working.  So it's like it's missed an event or
signal, and the signal never gets run a second time.  I forget what this is
called, but it's a classic multi-threaded programming bug.  At least it's got
those symptoms.

This is the output of PS for the only binary that had mozilla in the name:

kbohling  4555  0.4 15.0 122376 38324 ?      S    Aug29  27:24
/usr/lib/mozilla-1.2.1/mozilla-bin -UILocale en-US

Comment 6 Warren Togami 2005-04-25 03:58:01 EDT
Is this still an issue?  I used to see this kind of behavior back then, but no
longer with modern software.  Closing CURRENTRELEASE.  Open a new bug if you see
this behavior again.
Comment 7 Kasper Dupont 2005-04-26 03:47:53 EDT
I haven't seen this problem for a long time. I think it disappeared after
upgrading from RH9 to FC1. I just tried following my own instructions on how to
reproduce this problem
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=89431#c16, using those
steps I was not able to reproduce it on FC3.

BTW I'm almost sure the problem was not in mozilla, but rather in glibc or the
kernel. Someone should verify if the problem exists in RHEL. If neither FC nor
RHEL is affected, then closing it was the right thing to do.

Note You need to log in before you can comment on or make changes to this bug.