Bug 902269 - local provider: All member users are not returned on looking up top level parent group.
Summary: local provider: All member users are not returned on looking up top level par...
Keywords:
Status: CLOSED DUPLICATE of bug 895132
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-21 09:36 UTC by Kaushik Banerjee
Modified: 2020-05-02 17:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-21 10:33:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github SSSD sssd issues 2817 None closed local provider: All member users are not returned on looking up top level parent group. 2020-05-02 17:14:58 UTC

Description Kaushik Banerjee 2013-01-21 09:36:33 UTC
Description of problem:
All member users are not returned on looking up top level parent group

Version-Release number of selected component (if applicable):
1.9.2-74

How reproducible:
Always

Steps to Reproduce:
1. sssd.conf domain section:
[domain/LOCAL]
id_provider = local

2. Add the groups as follows:
parent(member: user1, child)
child(member: user2)

3. 
# sss_groupadd parent
# sss_groupadd child
# sss_groupmod -a parent child
# sss_useradd user1
# sss_useradd user2
# sss_usermod -a parent user1
# sss_usermod -a child user2
# getent -s sss group parent
parent:*:1000:user1         <== user1,user2 should have been returned.

  
Actual results:
Child member is not returned on lookup up parent group.

Expected results:
All members should be returned.

Additional info:
This was working as expected till version 1.9.2-68

Comment 2 Jakub Hrozek 2013-01-21 09:45:53 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1775

Comment 3 Jakub Hrozek 2013-01-21 10:12:28 UTC
(In reply to comment #0)
> This was working as expected till version 1.9.2-68

It was, but pretty much by accident only because nobody requested the parent group before. The root cause of the bug is that when we modify the parent group with "sss_usermod -a parent user1" we invalidate the memory entry of parent in memory cache, but we only invalidate the child group when adding user2 into it.

The proper fix is to invalidate all parent groups of groups being modified, too.

Comment 4 Kaushik Banerjee 2013-01-21 10:33:57 UTC

*** This bug has been marked as a duplicate of bug 895132 ***


Note You need to log in before you can comment on or make changes to this bug.