Bug 902282 - the tuxguitar guitar tuner plugin is not present
Summary: the tuxguitar guitar tuner plugin is not present
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tuxguitar
Version: 17
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-21 10:04 UTC by ycollet
Modified: 2013-02-08 02:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-08 02:05:53 UTC


Attachments (Terms of Use)

Description ycollet 2013-01-21 10:04:36 UTC
Description of problem:

The tuxguitar guitar tuner plugin is absent from the installed package.


Steps to Reproduce:

in /usr/share/tuxguitar/plugins/
A file tuxguitar-tuner.jar should be present but it's not.
  
Actual results:

Not possible to tune a guitar directly from tuxguitar.

Comment 1 Orcan Ogetbil 2013-01-21 17:31:21 UTC
The upstream disables this plugin by default. I enabled it, but I couldn't find a way to get it work. Does this work for you? Here is a scratch build with the tuner plugin enabled that you can test:
   http://koji.fedoraproject.org/koji/taskinfo?taskID=4890316

Comment 2 ycollet 2013-01-21 17:46:28 UTC
Works fine for me but:
- do not use jack nor the fluidsynth output
- select the gervill output.
Once selected, the tuner plugin starts to react.
Select one string to be tuned and play.

Thanks for your answer,

Best regards,

YC

Comment 3 Orcan Ogetbil 2013-01-22 02:55:29 UTC
I can't get it working here. But since it works for you, it will work some other people. I will rebuild tuxguitar with the tuner plugin. By the way, we also have a nice software called "guitarix" that can do tuning among other cool stuff. Just to let you know.

Thanks,
Orcan

Comment 4 Fedora Update System 2013-01-22 04:13:43 UTC
tuxguitar-1.2-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tuxguitar-1.2-10.fc18

Comment 5 Fedora Update System 2013-01-22 04:14:30 UTC
tuxguitar-1.2-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tuxguitar-1.2-10.fc17

Comment 6 Fedora Update System 2013-01-23 16:17:43 UTC
Package tuxguitar-1.2-10.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tuxguitar-1.2-10.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1347/tuxguitar-1.2-10.fc17
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-02-08 02:05:55 UTC
tuxguitar-1.2-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2013-02-08 02:13:05 UTC
tuxguitar-1.2-10.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.