Bug 90238 - lockd: can't encode arguments: 5
lockd: can't encode arguments: 5
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-05 17:13 EDT by Bruce Garlock
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 15:06:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Garlock 2003-05-05 17:13:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

Description of problem:
I get the following error when clicking on a SAMBA folder, that contains a
directory that is an NFS mount to a SCO Openserver 5.0.6 machine using RH AS 2.1

I did have this problem with RH 6.2, which I recently upgraded from on this machine.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:
Comment 1 Bruce Garlock 2003-05-05 17:14:40 EDT
OOps, meant to say, I did *not* have this problem under RH 6.2  - I had never
seen the error before.
Comment 2 Bruce Garlock 2003-05-08 13:12:09 EDT
I can further reproduce this error by doing the following:

mount an NFS dir to a SCO OpenServer 5.0.5 machine, using this mount command in

/etc/fstab on the AS 2.1 box:

note: Garlock is the SCO 5.0.5 machine

Garlock:/usr/covalent/users/mark /home/samba/work/users/mark/covalent nfs
rsize=16384,wsize=16384,soft,intr

The directory is the accessed as a SAMBA share on the AS 2.1 box, making the
NFS directory appear as a "regular" directory on the AS 2.1 box.

On the SCO side, this is my export entry for the NFS share:

/usr/covalent/users/mark -rw=linux.server

where linux.server is the AS 2.1 box.

As I said before, all this worked fine under RH 6.2, and I never had an issue. 

We use the SCO machine to export a procedure the the export folder in Lotus
1-2-3 format, then the user will open the file, and get the error "File in
Use", when in fact it is not in use.	The linux box then logs the error:

lockd: can't encode arguments: 5

I used a RH 9 machine to mount the same NFS directory, and could not get the
error.  The error occurs *every* time on the 2.1AS box, when the file is
initially accessed.  Subsequent access to the file seems to open it up just fine.

Note You need to log in before you can comment on or make changes to this bug.