Bug 90243 - cd writer hangs while writing
cd writer hangs while writing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-05 18:03 EDT by Joel Uckelman
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 16:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2003-05-05 18:03:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
After upgrading from RH8 to RH9, my GCE-8520B cd writer connected via USB 2.0
started freezing in the middle of burns when using cdrecord. There is no apprent
pattern to when during the burn the freeze occurs, save that it always happens
during the write and not during fixation. If I wait long enough (several
minutes), cdrecord returns the following error message:

faio_wait_on_buffer for writer timed out

but never exits itself. There are no other error messages that I've found,
neither in /var/log/messages, nor in dmesg.

After some experimentation, I found that the following combinations of stock
kernels and cdrecord versions work, indicated by plusses:

           cdrecord 2.0-6   1.10-14
kernel
2.4.18-27.8.0         +        +
2.4.20-8              -
2.4.20-9              -        +

When using the older cdrecord with the newest kernel, the same error message
appears when cdrecord exits, but burns appear to work fine.

I'm invoking cdrecord like this:

cdrecord -v driveropts=burnfree speed=52 dev=0,0,0 -data some.iso

I've tried writing isos of different sizes, and with the same results, so it's
not the particular iso I'm trying to write, nor is it the hardware since it
appears to be functional. Moreover, I've attempted burns at many different
speeds, and nothing seems to make a difference. At this point, it seems to me
that the problem is either with the kernel or cdrecord.


Version-Release number of selected component (if applicable):
2.4.20-9

How reproducible:
Always

Steps to Reproduce:
1. Try burning a cd with cdrecord 2.0-6, kernel 2.4.20-9, and a GCE-8520B cdrw
connected via USB 2.0.

Actual Results:  The cd writer ruins the blank, freezes, and can't be used again
without cycling it's power  and reloading the relevant kernel modules.

Expected Results:  The cd should burn properly.

Additional info:

I suspect that this bug may be related to 81656, 88688, and 84160.
Comment 1 Pete Zaitcev 2003-06-03 16:42:29 EDT
The 2.4.20-13 went out crooked in usb department, so skip it, please.
I hear some good news about 2.4.20-18, e.g. it "unhangs" an HP 8200e burner.
It is somewhat similar. Please try the -18 and let me know how it goes.
Comment 2 Joel Uckelman 2003-06-17 12:39:31 EDT
I upgraded to 2.4.10-18, and was able to burn successfully a CD with cdrecord
2.0-6. So it seems that, at least in my case, whatever had been wrong has been
corrected in the newer kernel.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.